Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

traceroute to adress in private network

I have 2 routers in my network.

172.16.0.0/12 - private intranet.

ple-rt#show ip route 172.28.23.1

Routing entry for 172.28.16.0/21

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 172.28.254.2

Route metric is 0, traffic share count is 1

ple-rt#traceroute 172.28.23.1

Type escape sequence to abort.

Tracing the route to 172.28.23.1

1 172.28.23.1 [AS 21017] 0 msec 0 msec 4 msec

ple-rt#traceroute 172.27.63.1

Type escape sequence to abort.

Tracing the route to 172.27.63.1

1 89.x.x.218 4 msec 0 msec 4 msec

2 172.27.63.1 [AS 21017] 0 msec 0 msec 4 msec

ple-rt#show run | b bgp

router bgp 15930

no synchronization

bgp log-neighbor-changes

network 89.18.128.0 mask 255.255.240.0

aggregate-address 89.18.128.0 255.255.240.0 summary-only

neighbor 80.82.34.77 remote-as 21017

neighbor 80.82.34.77 update-source GigabitEthernet0/1.904

neighbor 80.82.34.77 version 4

neighbor 80.82.34.77 send-community

neighbor 80.82.34.77 prefix-list peers-out out

neighbor 80.82.34.77 route-map setcommunity out

neighbor 80.82.63.250 remote-as 65530

neighbor 80.82.63.250 update-source GigabitEthernet0/1.202

neighbor 80.82.63.250 prefix-list wipline-net out

neighbor 172.16.0.1 remote-as 8981

neighbor 172.16.0.1 update-source GigabitEthernet0/1.15

neighbor 172.16.0.1 prefix-list wipline-net out

neighbor 213.129.97.165 remote-as 24923

neighbor 213.129.97.165 update-source GigabitEthernet0/1.900

neighbor 213.129.97.165 version 4

neighbor 213.129.97.165 prefix-list peers-out out

no auto-summary

!

ple-rt#show run | b router\ eigrp

router eigrp 100

network 89.x.x.216 0.0.0.3

no auto-summary

eigrp router-id 89.x.x.217

!

router eigrp 110

network 172.29.92.0 0.0.0.127

network 172.29.93.0 0.0.0.127

network 172.29.94.16 0.0.0.7

network 172.29.128.0 0.0.63.255

no auto-summary

eigrp router-id 172.29.94.18

!

question: Why does traceroute shows [AS 21017] for my private adresses?

6 REPLIES

Re: traceroute to adress in private network

Hi,

Let me take a guess, are you using MPLS VPN, and the AS of your provider is "21017"?

BR,

Mohammed Mahmoud.

Re: traceroute to adress in private network

No, I'm not using MPLS VPN. 21017 is AS of my provider.

Probably, this is default route?

How can i fix it?

ple-rt#sh ip bgp 172.28.23.1

BGP routing table entry for 0.0.0.0/0, version 33343350

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Not advertised to any peer

21017

80.82.34.77 from 80.82.34.77 (80.82.57.79)

Origin IGP, localpref 100, valid, external, best

Re: traceroute to adress in private network

Hi,

If not MPLS VPN then what kind of VPNs are you running here, a simple topology will help here.

Yes its a default route received from your provider thats why it is with his AS, this shouldn't be making any problems.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Re: traceroute to adress in private network

There is no any VPN service. Just direct optic.

Re: traceroute to adress in private network

Hi,

Do you mean that you have a direct link between your 2 routers ?

Can you please provide a simple topology diagram for all the connections that you have on both your routers.

BR,

Mohammed Mahmoud.

Re: traceroute to adress in private network

Hi!

ISP1(AS 21017) <-optic-> |Rtr A|<-optic->|Rtr B|

ISP2(AS 24923) <-optic->

This is primary link between my routers and my ISPs. Also I have reserve link via radio between my routers:

interface Tunnel0

description backup link on rtrA

ip address 172.29.94.38 255.255.255.252

ip mtu 1514

ip route-cache policy

ip route-cache flow

ip policy route-map comlink-gw

tunnel source 172.29.94.9

tunnel destination 172.29.94.1

!

!!!used for primary link

router eigrp 100

network 89.xx.xx.216 0.0.0.3

no auto-summary

eigrp router-id 89.xx.xx.217

!

!!!used for reserve

router eigrp 110

network 172.29.92.0 0.0.0.127

network 172.29.93.0 0.0.0.127

network 172.29.94.16 0.0.0.7

network 172.29.128.0 0.0.63.255

no auto-summary

eigrp router-id 172.29.94.18

!

146
Views
3
Helpful
6
Replies
CreatePlease to create content