Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

tracking on interfaces

Hello everybody,

I give you my problem:

My ultimate goal is to have a load-balancing using one router 2811(two WAN interfaces and one fastethernet), for that I use route-map.

For the moment something is not implemented, Indeed, if my WAN interface is UP but unfunctional,the router will continue to load-balance ...

That's why I would like to use track which permit,if an inteface is unfonctional, redirect all traffic on the second.

I find many solution with HSRP, but I don't want to use it.

I can't use BGP too: it's impossible for me to configure my ISP's routers.

I can't use Linux ^^ .

Someone would have an idea ?

Thank for your answers

My config:

interface FastEthernet0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface ATM0/0/0

ip address dhcp

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

oam-pvc manage

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface ATM0/1/0

ip address dhcp

ip nat outside

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer0

ip address negotiated

no ip unreachables

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname ********@neuf.fr

ppp chap password 7 ***************

!

interface Dialer1

ip address negotiated

no ip unreachables

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname fti/***********

ppp chap password 7 ************

!

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

ip nat inside source route-map RouteMap1 interface Dialer0 overload

ip nat inside source route-map RouteMap2 interface Dialer1 overload

!

route-map RM2 permit 10

match ip address name MonLan

match interface ATM0/1/0

!

route-map RM1 permit 10

match ip address name MonLan

match interface ATM0/0/0

!

2 REPLIES

Re: tracking on interfaces

Hi,

you should look for SAA Tracking. Its available for ATM interface as well.

You can track a link end to end or else track the interface status.

This is going to really help if you terminate the WAN link on ethernet, since the ethernet connectivity between the router and the device on which the actual WAN link is terminated will still remain up even if the actual wan link goes down.

Following are few links -

http://www.cisco.com/en/US/docs/ios/12_4/ip_route/configuration/guide/h_pbrtrk.html

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t11/feature/guide/ftatmslm.html

-> Sushil

New Member

Re: tracking on interfaces

thanks for all sushil.katre@wipro.com

I will try everything today

100
Views
0
Helpful
2
Replies