Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Traffic Shaping - Frame Relay

Hi All:

Taking my first stab a traffic shaping on a Frame Relay Circuit. Read a Cisco article on it but it doesn't seem as straight forward as I hoped.

We have 3 T1 MFR circuit and I want to allow smtp let's say, to 25% of the bandwidth out. How can I accomplish this in the easiest manner possible. Nothing fancy needed.

Thanks.

Joe

8 REPLIES

Re: Traffic Shaping - Frame Relay

Hello Joe,

well what is easy in IT? ;-)

One solution is:

class-map match-all SMTP

match protocol smtp

policy-map FRshape

class SMTP

shape average percent 25

interface Serial0/0

encapsulation frame-relay IETF

frame-relay traffic-shaping

interface Serial0/0.100 point-to-point

ip address ...

frame-relay interface-dlci 100

class DLCIshape

!

map-class frame-relay DLCIshape

frame-relay cir 64000

service-policy output FRshape

What you do there is to specify smtp traffic to belong to the class SMTP. Then you define a policy that does shape the traffic in this class to 25% of the interface bandwidth and apply it to the DLCI 100 with the help of a FR class.

You can monitor the outcome by "show policy interface Serial0/0.100". Adjust the config to your interface naming, DLCI number and bandwidth.

Hope this helps! Please rate all posts

Regards, Martin

New Member

Re: Traffic Shaping - Frame Relay

Thanks Martin - I'll give it a try

New Member

Re: Traffic Shaping - Frame Relay

Martin - tried this and had some difficulties. Defined the policy fine but had an issue mapping it to an interface. Also, from the posts below, I also need to understand the frame-relay cir 64000 line in the config. I am assuming that this is total available bandwidth on the circuit....in this case 64K ? For a 3T bundle we would be talking roughly 4600K?

Perhaps if I posted my config it would help. Appreciate your input.

ip cef

no ip domain lookup

!

no ip bootp server

frame-relay switching

no frame-relay address registration ip

!

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 1/0

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/1

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/2

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

controller T1 1/3

framing esf

linecode b8zs

channel-group 0 timeslots 1-24 speed 64

!

!

!

interface MFR1

mtu 4470

no ip address

no ip proxy-arp

encapsulation frame-relay IETF

no ip route-cache cef

no ip mroute-cache

load-interval 30

no arp frame-relay

frame-relay multilink bid to gw

frame-relay lmi-type ansi

!

interface MFR1.500 point-to-point

ip address 140.x.x.x 255.255.255.252

no ip proxy-arp

ip nat outside

no arp frame-relay

no cdp enable

frame-relay interface-dlci 500 IETF

!

interface FastEthernet0/0

description PRODUCTION

ip address 10.0.2.1 255.255.255.0

ip nat inside

ip route-cache same-interface

no ip mroute-cache

duplex auto

speed auto

no cdp enable

hold-queue 450 in

!

interface FastEthernet0/1

description CORP LINK

ip address 10.0.4.1 255.255.255.0

ip nat inside

ip route-cache same-interface

duplex auto

speed auto

no cdp enable

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

no cdp enable

!

interface Serial1/0:0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

no ip proxy-arp

encapsulation frame-relay MFR1

no arp frame-relay

!

interface FastEthernet1/1

description LINK TO 3x FIREWALL WAN PORT

ip address 65.x.x.x 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Serial1/1:0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

encapsulation frame-relay MFR1

no arp frame-relay

!

interface Serial1/2:0

mtu 4470

bandwidth 1536

no ip address

no ip redirects

encapsulation frame-relay MFR1

no arp frame-relay

Re: Traffic Shaping - Frame Relay

Hello,

you should apply the service-policy to the FR PVC, something like:

interface MFR1

mtu 4470

no ip address

no ip proxy-arp

encapsulation frame-relay IETF

frame-relay traffic-shaping

interface MFR1.500 point-to-point

ip address 140.x.x.x 255.255.255.252

no ip proxy-arp

ip nat outside

no arp frame-relay

no cdp enable

frame-relay interface-dlci 500 IETF

class DLCIshape

!

map-class frame-relay DLCIshape

frame-relay cir 4600000

service-policy output FRshape

What are the problems you are facing, when trying to apply the policy?

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Traffic Shaping - Frame Relay

The problem I encountered was with the sub-interface. I'm not quite sure what the line class DLCIshape accomplishes and what command was issued that resulted in that line being added to the sub-interface. Everything else was pretty straightforward.

I also had a question regarding the bandwidth parameter which I see now is total bandwidth of the bundle expressed in bytes..correct?

Thanks alot Martin, appreciate your time on this.

Joe

VIP Purple

Re: Traffic Shaping - Frame Relay

Hello,

in addition to Martin´s post, and if you want to read up a little more on Frame Relay Traffic Shaping, you might want to have a look at the link below, which is (I think) a really good and fairly easy to understand explanation of the technology:

Understanding Frame Relay Traffic Shaping

http://www.internetworkexpert.com/resources/01700368.htm

Regards,

GP

New Member

Re: Traffic Shaping - Frame Relay

Just a quick question. Wouldn't configuring a CIR of 64k in the map-class effectively shape SMTP to 25% of that (resulting in shaping SMTP @ 16k) ? When configured this way, I believe it will use the configured CIR as opposed to the total bandwidth available on the MFR bundle. Could be wrong.

New Member

Re: Traffic Shaping - Frame Relay

Just read the initial reply again. I see the note where it suggests adjusting BW, interface, etc...

251
Views
4
Helpful
8
Replies
CreatePlease to create content