Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

traffic shaping

We would like to limit the portion of our outbound (serial0) bandwidth used by a particular server. We want to create an access list group containing that server's IP address, and then put that access list group into a traffic shaping statement. Can anyone provide an example of the commands necessary to implement?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: traffic shaping

Hello,

basically, you have a couple of options to accomplish this. Let's say your server has IP address 192.168.1.1, and you want to limit the bandwidth to 200K on your serial interface. Let's also assume that your WAN link has 512K of bandwidth available.

Your configuration would look like this:

interface Serial0

bandwidth 512

fair-queue

traffic-shape group 1 200000 250000

!

access-list 1 permit 192.168.1.1

Or you could simply rate-limit on your serial interface:

interface Serial0

rate-limit output access-group 1 200000 4000 6000 conform-action continue exceed-action drop

!

access-list 1 permit 192.168.1.1

Another alternative would be to use CBWFQ:

class-map match-all LIMIT

match access-group 1

!

policy-map SERIAL

class LIMIT

bandwidth 200

!

interface Serial0

service-policy output SERIAL

!

access-list 1 permit 192.168.1.1

Can you try any of these configs and see if that works for you ?

Regards,

GP

4 REPLIES

Re: traffic shaping

Hi

if you want to configure a kinda limiting only then would suggest to check out for CAR (rate-limit).

You can achieve the limiting in conjuntion with the ACLs with the rate-limit statement.

do refer these links for more on both CAR and shaping..

http://cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a00800ca594.html

http://cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800bd8ef.html

regds

VIP Purple

Re: traffic shaping

Hello,

basically, you have a couple of options to accomplish this. Let's say your server has IP address 192.168.1.1, and you want to limit the bandwidth to 200K on your serial interface. Let's also assume that your WAN link has 512K of bandwidth available.

Your configuration would look like this:

interface Serial0

bandwidth 512

fair-queue

traffic-shape group 1 200000 250000

!

access-list 1 permit 192.168.1.1

Or you could simply rate-limit on your serial interface:

interface Serial0

rate-limit output access-group 1 200000 4000 6000 conform-action continue exceed-action drop

!

access-list 1 permit 192.168.1.1

Another alternative would be to use CBWFQ:

class-map match-all LIMIT

match access-group 1

!

policy-map SERIAL

class LIMIT

bandwidth 200

!

interface Serial0

service-policy output SERIAL

!

access-list 1 permit 192.168.1.1

Can you try any of these configs and see if that works for you ?

Regards,

GP

New Member

Re: traffic shaping

I've implemented the first option, we'll keep an eye on it during peak time and see what happens.

Thanks for your help.

New Member

Re: traffic shaping

HI

Curious to know which of the two option suggested by George above are recomended. I think rate limit will simply drops the access packets (which may be good for security related implimentaiton) where as the 2nd option of limiting the BW may delay the packets going thr' the interface. (packets may be queued upto some extent). This may make difference for application traffic which is being shaped.

200
Views
0
Helpful
4
Replies
CreatePlease to create content