Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Transport Performance Optimization Modules

Hi,

Did anybody worked maybe on AIM-TPO-2 modules? I'm having a little problem with configuration. I made simple configuration in the lab and made little test but unfortunatelly it seems that there is no compressin in between - test traffic is pute ftp.

What I'm not 100% sure is 'sctp-peer peer' what IP address should be used as peer in each module?

As explanation I've PC connected to Gi0/0 interface on Router A with 192.168.41.11 IP and I'm trying to transfer some files over FTP to Server (169.16.0.11) connected to Gi0/0 interface on Router B. I tried to transfer some bigger pdfs but never saw any increase in speed

Configuraiton from both routers attached below:

--- Router A ---

version 12.4
!

<...>

!
boot-start-marker
boot system flash c2800nm-ipbasek9-mz.124-24.T2.bin
boot-end-marker
!
<...>!
!
interface Loopback0
ip address 128.10.0.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 192.168.41.241 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex full
speed 100
!
interface GigabitEthernet0/1
ip address 172.16.10.1 255.255.255.0
duplex full
speed 10
transport-opt 1 interface Transport-Opt-Service-Engine0/0
!
interface Transport-Opt-Service-Engine0/0
description *** Compression Module ***
ip unnumbered Loopback0
ip virtual-reassembly
service-module ip address 128.10.0.10 255.255.255.0
service-module ip default-gateway 128.10.0.1
hold-queue 60 out
!

ip route 128.10.0.10 255.255.255.255 Transport-Opt-Service-Engine0/0
ip route 169.16.0.0 255.255.255.0 GigabitEthernet0/1
!
<...>
!
end

Router A Module

tpo id 1
default policy-action  compress-sctp
bandwidth-profile high-speed-sctp
sctp-peer 172.16.0.10 tos 0
sctp-peer 172.16.0.10 tos 1
sctp-peer 172.16.0.10 tos 2
sctp-peer 172.16.0.10 tos 3
sctp-peer 172.16.0.10 tos 4
sctp-peer 172.16.0.10 tos 5
sctp-peer 172.16.0.10 tos 6
sctp-peer 172.16.0.10 tos 7
exit

--- Router B ---

version 12.4

!
<...>
!
boot-start-marker
boot system flash c2800nm-ipbase-mz.124-24.T2.bin
boot-end-marker
!
<...>

!

interface Loopback0
ip address 128.20.0.1 255.255.255.0
!
interface GigabitEthernet0/0

ip address 169.16.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 172.16.10.10 255.255.255.0
duplex full
speed 10
transport-opt 1 interface Transport-Opt-Service-Engine0/0
!
interface Transport-Opt-Service-Engine0/0
description *** Compression Module ***
ip unnumbered Loopback0
ip virtual-reassembly
service-module ip address 128.20.0.10 255.255.255.0
service-module ip default-gateway 128.20.0.1
hold-queue 60 out
!

ip route 128.20.0.10 255.255.255.255 Transport-Opt-Service-Engine0/0
ip route 192.168.41.156 255.255.255.255 GigabitEthernet0/1
!
<...>

!

end

Router B Module

tpo id 1
default policy-action  compress-sctp
bandwidth-profile high-speed-sctp
sctp-peer 172.16.0.1 tos 0
sctp-peer 172.16.0.1 tos 1
sctp-peer 172.16.0.1 tos 2
sctp-peer 172.16.0.1 tos 3
sctp-peer 172.16.0.1 tos 4
sctp-peer 172.16.0.1 tos 5
sctp-peer 172.16.0.1 tos 6
sctp-peer 172.16.0.1 tos 7
exit

Thanks in advance,

Bart

Everyone's tags (3)
211
Views
0
Helpful
0
Replies