Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Trouble shooting of Static NAT

Hi,

I have a trouble about Static NAT such as following senario.

Ping command from PC to Router_B's s0 was faild.

C:\>ping 10.1.1.2

Pinging...

Request timed out.

Could you tell me how to troubleshoot this senario?

Regards,

JAPANESE-ENGLISH TRANSLATION FOR THE FIGURE BELOW

<Static NAT>

Inside Local  -->  Inside Global

172.16.1.2   (trans)  200.1.1.1

nat301.jpg

                                                              Internet

                                                              Router_B

<Router_A >

Building configuration...

Current configuration : 1011 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_A

!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$q/hX$ENdPcT6Cr7KZD1elbAYqH/
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
username cisco password 0 cisco
!
!
interface Serial0/0
bandwidth 64
ip address 10.1.1.1 255.255.255.0
ip nat outside
ip virtual-reassembly
no fair-queue
clock rate 64000
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
!
ip http server
no ip http secure-server
ip nat inside source static 172.16.1.2 200.1.1.1
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login local
line vty 5 181
login local
!
!
end

<Router_B>

Building configuration...

Current configuration : 847 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router_B
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
no fair-queue
!
interface FastEthernet0/0
ip address 172.18.0.1 255.255.0.0
shutdown
duplex auto
speed auto
!
ip route 200.1.1.0 255.255.255.0 10.1.1.1
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Trouble shooting of Static NAT

Hi Tom

Your NAT scenario is wrong, if its point to point you dont need a NAT over on the 64K link.

You need to make sure that you define proper NAT MAP and the inside/outside NAT interfaces as well.

Also you need to make sure that you have proper routes in place on both the routers.

Do give in more info on what you are trying to simulate or achieve out there.

regds

3 REPLIES

Re: Trouble shooting of Static NAT

Hi Tom

Your NAT scenario is wrong, if its point to point you dont need a NAT over on the 64K link.

You need to make sure that you define proper NAT MAP and the inside/outside NAT interfaces as well.

Also you need to make sure that you have proper routes in place on both the routers.

Do give in more info on what you are trying to simulate or achieve out there.

regds

New Member

Re: Trouble shooting of Static NAT

Hi, spremkumar.

Thank you for your reply.

And I'm sorry for my late resposce.

I had cought a cold.

So, this scinario published in someone's blog which contains a lot of missptint is written for a lesson of a Static NAT.

Reading this site, I prepared two routers 2611XM( IOS 12.4 AES). And I configured as above based on the blog's model answers.

●Router_A

!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router_A
!
enable password cisco
!
interface Serial0
ip address 10.1.1.1 255.255.255.0
ip nat outside
clockrate 64000
!
interface Serial1
no ip address
shutdown
!
interface FastEthernet0
ip address 172.16.1.1 255.255.0.0
ip nat inside
speed auto
!
ip nat inside source static 172.16.1.2 200.1.1.1
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end


●Router_B

!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router_B
!
enable password cisco
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.1.1.2 255.255.255.0
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip classless
ip route 200.1.1.0 255.255.255.0 10.1.1.0
logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password cisco
login
!
end

Blog saids "You can establish a connection PC to Router_B. Ping now."

If this scenario is wrong, Could you improve this scenario for studying Static NAT?

Regards,

New Member

Re: Trouble shooting of Static NAT

Hi,

I'm so sorry... I was so wrong.

I forgot to configure "ip nat inside" at FastEthernet0/0 as shown in my first posting,

> !
> interface FastEthernet0/0
> ip address 172.16.1.1 255.255.255.0
> duplex auto
> speed auto
> !

Thank you spremkumar.

Regards,

307
Views
0
Helpful
3
Replies
CreatePlease to create content