Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Troubles with Cisco 820 ADSL router

Hello

I am having trouble with my Cisco 820 ADSL router in that I am trying to connect a Snap Gear Firewall between the router's eth port and the LAN. However for some or other reason the 2 don't want to communicate.

The Snap Gear has a WAN interface with ip 192.168.0.253/24 the LAN interface is 192.168.0.252/24. No ACL's on the snapgear.

The eth0 port on the C820 has some ACL's and after removing them they still don't want to communicate. When the C820 and the snapgear are both connected to separate ports on the switch the 2 can ping each other just fine.

The one problem I am facing is the NAT'ing set up on the C820. I am not sure if that is actually causing the hiccup although I suspect so as it is set up between the LAN and WAN interfaces on the router. From what I can see the NAT should automatically pick up the snapgear's firewall interfaces and assign addresses to them as NAT has been set up dynamically with 2 static conversions. However this does not happen.

I am including the Cisco configs and would appreciate some help.

Many Thanks

wvw

  • WAN Routing and Switching
2 REPLIES
New Member

Re: Troubles with Cisco 820 ADSL router

If I'm understanding you correctly when they are connected via the switch the are fine but directly connected they won't talk. If so yhave you tried a crossover patch lead?

New Member

Re: Troubles with Cisco 820 ADSL router

Hello Tom

Yes, you are understanding me correctly. However, the Snapgears are known to work with straight through cables.

I have installed a few others at some other sites and they worked fine with a straight through cable.

Thanks for the reply. I guess I'll need to scratch around some more.

regards

willemvw

130
Views
0
Helpful
2
Replies