Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Trunk link problem

Hi All,

I am configuring a trunk link betweem cisco 7206VXR and Cat6509.The link is up and connected.The connection between router and switch is on the same Vlan 200.I have tried using access mode but no luck.Would like to know whether my config is Ok?

But am not able to ping the sub-interface of the router from Cat6509.

Can anyone guide me with the configs.I am testing a VRRP scenario,so there are other switches in the topology.

Thanks in Advance

Cisco7206VXR

-------

interface FastEthernet4/0.200

encapsulation dot1Q 200

ip address 10.0.0.2 255.255.255.0

vrrp 4 timers learn

vrrp 4 ip 10.0.0.1

vrrp 4 priority 254

end

Cat6509

--------

interface GigabitEthernet1/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200

switchport mode trunk

no ip address

end

9 REPLIES
Silver

Re: Trunk link problem

Could you provide the vlan config. of 6509 and also the show trunk / vlan in both equipment ? Thx.

If you are using IOS newer than 12.1(3)T in 7200. Try below command if VLAN 200 is native VLAN.

interface FastEthernet4/0.200

encapsulation dot1Q 200 native

Hope this helps.

New Member

Re: Trunk link problem

Thanks Jack for your quick response.

My 7206VXR is using IOS 12.0(18)S1, will upgrade the IOS to enable the native keyword.

I will give you the whole scenario for your quick understanding.Should I need to add a new vlan in the cat 6509 as native vlan other than Vlan1?

Cisco 7206VXR-1

-------------

sh vlan

Virtual LAN ID: 200 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: FastEthernet4/0.200

Protocols Configured: Address: Received: Transmitted:

IP 10.0.0.2 193 134222

Cat6509-1

-------

sh int trunk

Port Mode Encapsulation Status Native vlan

Gi2/1 on 802.1q trunking 1

Port Vlans allowed on trunk

Gi2/1 200

Port Vlans allowed and active in management domain

Gi2/1 none

Port Vlans in spanning tree forwarding state and not pruned

Gi2/1 none

sh int switchport

Name: Gi1/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 200

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Thanks

Cisco Employee

Re: Trunk link problem

Hi Friend,

When you say you are not able to ping from your 6509 to the router sub intrerface for vlan 200 can you please confirm what all layer 3 interfaces you have on cat6509?

WHY I am asking this is because I believe you are having routing for vlans on your router and you have only allowed vlan 200 on that trunk link so if you will ping from cat6509 the source ip of ping packet if it will be something else then vlan 200 the ping will not work. So if you allow other vlans on your cat6509 trunk it should ping.

Also I believe in your same setup if you connect any host on vlan 200 on any physical layer 2 port you should be able to ping your vlan 200 sub interface.

Please update the result.

HTH

Ankur

New Member

Re: Trunk link problem

Hi Ankur,

Thanks for your suggestions.

My entire config is attached which will confirm all layer 3 interfaces on cat6509.

I haven't tried connecting a host on vlan 200 to check the ping to the sub interface,will try that.

Your advice is appreciated on the config part.

Thanks in Advance

Hall of Fame Super Bronze

Re: Trunk link problem

Beno,

I see some problems with your config

1) You don't have Layer2 VLAN created in the 6509. I can confirm this with this command.

Port Vlans allowed and active in management domain

Gi2/1 none

Can you post the output from typing 'show vlan' on this switch ?

2)

From the config you posted, it seems you are using the 6509 ports as L3 ports but on the portion that does not work, it's acting like a L2 port. If you decide going with L2 configuration, you need to create a SVI for VLAN 200 and assign an IP to it.

3) The trunk on G1/1 is down

sh int switchport

Name: Gi1/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Can you please post the entire config ? It would help troubleshooting.

Thanks

New Member

Re: Trunk link problem

Hi Edison,

Thanks for your advice.

Q1>>

sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

Vlan 200 is not created

Q2>>

Do I need a SVI interface for this?

Anyway I tried creating a SVI interface as

int vlan 200

ip address x.x.x.x

But still am not able to ping 10.0.0.2

Q3>>

Entire config is attached.

I am able to ping from Cat6509-1 to 10.0.0.5,but not to 10.0.0.2.I think am wrong with my configs,can you please help me out?

Thanks,

Beno

Silver

Re: Trunk link problem

Do you mean when you use SVI interface, you can ping from 6509-1 to 10.0.0.5 but not .2 ?

What is the original IP address in 6509-1 ?

According to the entrie config, there is no IP config for 6509-1. Please advise.

Moreover, you need to create VLAN 200 in switch if you are using trunk.

Moreover, are you sure to use 192.x subnet in VLAN 200 that same with subnet 10.x ?

New Member

Re: Trunk link problem

Thanks Everyone who has assisted me.

It works without any SVI interface on 6509-1,able to ping the sub interface.It was my routers problem did a reload,everything got fixed.

Was a good learning from all you guys about various concepts.

I will start this post again for any other redundancy issues.

Jack,

No I did not use SVI interface,it was suggested by one of the Netpros.

You are correct there are no IP configs for 6509-1

Vlan 200 is created in 6509-1

Yes,I can use 192.x subnet in VLAN 200 that same with subnet 10.x

Silver

Re: Trunk link problem

Thanks for the update. And you carried the most important action is to reload the equipment. It is also one of the troubleshoot technique. :)

330
Views
18
Helpful
9
Replies
CreatePlease to create content