Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Trust DSCP on WS-X6348-RJ-45 using Native IOS

I need to be able to trust DSCP on the follow 10/100 module WS-X6348-RJ-45 running Native IOS. Currently I can't trust any thing and have to use the MQC type config to classify and mark packets...Problem is I don't know all the traffic that needs to be marked or what it needs to be marked(Avaya voice system)....I would like to trust the ports to at least figure that out....Anyone know of a way. I have done it in CatOS before.

7 REPLIES

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

QoS is by default disabled in 65XX.

Mls qos will enable qos globally on the switch

you can trust the port by using mls qos trust dscp or mls qos trust cos command

Narayan

Community Member

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

Actually that command does not work on the module I mentioned above...Believe me I tried that.

Hall of Fame Super Blue

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

Hi

As Narayan said you can use either "mls qos trust dscp" or "mls qos trust cos". Looking at our 6500 on our lab with the WS-X6348-RJ-45 module the "mls qos trust dscp" command is not available.

Do the Avaya phones mark the Cos value as well as you could use the "mls qos trust cos" command for this module.

HTH

Jon

VIP Gold

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

I ran into a similar problem and this may help. It is unfortunate that you cannot use the trust dscp command with this module and in some versions of code it let's you use it but it still won't work!

Regardless - If you have a general idea of the QoS/DSCP markings used by the Avaya system you can tell the switch to remark the packets with the same DSCP settings that are on the incoming packets. If you can sniff the port you may get a good idea of the markings so as not to make the process too cumbersome. See example below:

!

interface FastEthernet4/5

ip address 10.X.X.4 255.255.255.0

load-interval 30

speed 100

duplex full

service-policy input VOIP

!

!

!

Global config:

!

class-map match-all voice_ctl

match access-group 112

class-map match-all voice

match access-group 111

!

!

policy-map VOIP

class voice

set dscp ef

class voice_ctl

set dscp af31

!

!

!

access-list 111 permit ip any any dscp ef

access-list 112 permit ip any any dscp af31

!

!

Community Member

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

Thanks, That is a great idea to use the dscp values in the acl's. didn't know you could do that. I was trying to figure out the actually tcp and udp ports the Avaya system is using(which apparently isn't the default).

I will give it a shot.

Community Member

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

That did work great. I was able to see the packets and what ports are being used.

Thanks

VIP Gold

Re: Trust DSCP on WS-X6348-RJ-45 using Native IOS

That's great....glad I was able to help

654
Views
5
Helpful
7
Replies
CreatePlease to create content