Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Tunnel config

I configured Tunnel, but i am not able to ping my remote tunnel ip.ie 10.10.1.2 and vice-versa.

On Mumbai Router

inter fa 0/0

ip address 10.5.2.2 255.255.255.252

des "connected to WAN"

inter tunnel 0

ip address 10.10.1.1 255.255.255.252

tunnel source 10.5.2.2

tunnel destination 10.5.2.90

ip route 10.10.1.0 255.255.255.252 10.5.2.1

On Pune Router

inter fa 0/0

ip address 10.5.2.90 255.255.255.252

des "connected to WAN"

inter tunnel 0

ip address 10.10.1.2 255.255.255.252

tunnel source 10.5.2.89

tunnel destination 10.5.2.2

ip route 10.10.1.0 255.255.255.252 10.5.2.89

10 REPLIES
Cisco Employee

Re: Tunnel config

Arjun,

The source address of the tunnel interface on Pune should be the fa0/0 address 10.5.2.90 rather than 10.5.2.89.

Do you have a route on Mumbai to reach 10.5.2.90 ans inversely a route on Pune to reach 10.5.2.2.

Also, you do not need the static routes for 10.10.1.0/30 as these routes will be installed as a connected routes because of the tunnel interface.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Tunnel config

Thanx...

I'll Try and revert.

New Member

Re: Tunnel config

Thanx a Lot..

Now i am able to ping my remote tunnel IP.I have one more query.

I have one more backup ISP to Pune using BGP.I want redundancy.If my 1st ISP fail, 2nd will work.

can I create a second tunnel for that.

Currently for 1st ISP i am using static route.Is it possible to use same loopback address for both ISP.

I am very greatful to U.

New Member

Re: Tunnel config

Hi..

Any suggestion..

Cisco Employee

Re: Tunnel config

Arjun,

Could you please explain why you would need a GRE tunnel to your primary or backup ISP.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Tunnel config

Thanx...

I need autofailover to my both ISP.

Pune user should access Mumbai via 2nd ISP if my 1st ISP fail.

Thax Again..

Cisco Employee

Re: Tunnel config

Arjun,

And why do you need GRE tunnels to do that? Can't you do it without GRE? A diagram might be useful.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: Tunnel config

Thanx a lot..

I can do this without GRE.

My priority is Autofailover to my both ISP.For REL(MPLS VPN) i am using BGP and for VSNL (MPLS VPN) using static routes on my Mumbai router.

On Pune router i am using static routes for primary (REL).When REL down i manually change that routes toward VSNL.

Is there any way to autoswitchover route like using metric.

Pls find the attachment.

Re: Tunnel config

You can use conditional advertisemsnt on the router that is running BGP. Please check out "neighbor advertise-map non-exist-map"

http://www.cisco.com/en/US/docs/ios/12_1/iproute/command/reference/1rdbgp.html#wp1150201

New Member

Re: Tunnel config

Thax for u'r suggestion..

But on pune router i am not using BGP.There is a static route for ISP.

Is there any way..?

142
Views
0
Helpful
10
Replies