Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

Tunnel11: adjacency fixup,..

I have a T1 frame-relay connection to the internet on one router. On a second router, I have an HDLC T1 connection to the the internet. I form a ipsec protected tunnel between the two sites. When the tunnel comes up, and OSPF performs its adjacency, I start to get a tonne of 'adjacency fixup' messages, and my router cpu goes high. Any ideas as to why I get the messages? I have to 'shut' the tunnel to stop the messages.

interface Serial0/0/0:0

no ip address

encapsulation frame-relay IETF

load-interval 30

frame-relay lmi-type ansi

max-reserved-bandwidth 100

!

interface Serial0/0/0:0.1 point-to-point

ip address x.x.x.x 255.255.255.252

ip access-group aclBlockInbound in

ip access-group aclBlockOutbound out

no ip redirects

no ip unreachables

no ip proxy-arp

no cdp enable

frame-relay interface-dlci 16 IETF

interface Tunnel11

bandwidth 1024

ip address 172.20.x.x 255.255.255.252

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 7 xxxxx

ip ospf mtu-ignore

load-interval 30

qos pre-classify

keepalive 10 3

tunnel source Serial0/0/0:0.1

tunnel destination 64.x.x.x

tunnel mode ipsec ipv4

tunnel protection ipsec profile profForTun10

max-reserved-bandwidth 100

service-policy output pmShapeTun11

!

3 REPLIES

Re: Tunnel11: adjacency fixup,..

Hi,

Are you running CEF in that box?

Sundar

New Member

Re: Tunnel11: adjacency fixup,..

Yes, CEF is running on a 2821 with 12.4.7.

I did a 'clear ip ospf process' and the problem appears to have disappeared. I'm not sure if it will re-appear. I had been fooling with the bandwidth parameters on the tunnel (the bandwidth on the serial interface had been upgraded). Now that I have those configured, will it remain stable?

Hall of Fame Super Silver

Re: Tunnel11: adjacency fixup,..

Ray

To be able to answer that question we would need to have a little more information. In particular if you could post the OSPF configuration and the output of show ip ospf interface would be helpful.

Without knowing many details of what you are running I would make my first guess that the issue you were running into may have been a recursive routing issue with the tunnel. Recursive routing is a likely issue especially if the same dynamic routing protocol advertises the subnet of the tunnel address and announces the subnet of the tunnel destination.

HTH

Rick

928
Views
0
Helpful
3
Replies
CreatePlease to create content