Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Turn off BGP load balancing

I have 2 inputs for my internet link they are both the same speed. The config was setup for load balance and failover. I am upgrading one of the links to three times the speed and would like all traffic to use that link(Disable load Balance). And the other link for only failover. Any sugetions if this could be done or what changes need to be made in the config

ip subnet-zero

ip flow-cache timeout active 1

no ip domain lookup

ip audit notify log

ip audit po max-events 100

ip ssh time-out 60

no ftp-server write-enable

!

!

!

interface Multilink1

ip address 144.xxx.xxx.xxx 255.255.255.xxx

ip access-group 150 out

ip route-cache flow

ntp disable

no keepalive

fair-queue

no cdp enable

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/0

description connected to Provider 1

bandwidth 100000

ip address 69.xxx.xxx.xxx 255.255.255.xxx

ip access-group 150 out

ip route-cache flow

duplex auto

speed auto

ntp disable

no cdp enable

no mop enabled

!

interface Serial0/0

description connected to Provider 2

bandwidth 1544

no ip address

max-reserved-bandwidth 100

encapsulation ppp

ip route-cache flow

no fair-queue

no cdp enable

ppp multilink

ppp multilink group 1

!

interface FastEthernet0/1

description connected to Firewall

bandwidth 100000

ip address 206.xxx.xxx.xxx 255.255.255.0

ip access-group 112 in

ip route-cache flow

duplex auto

speed auto

ntp disable

no cdp enable

no mop enabled

!

interface Serial0/1

description connected to Provider 2

bandwidth 1544

no ip address

max-reserved-bandwidth 100

encapsulation ppp

ip route-cache flow

no cdp enable

ppp multilink

ppp multilink group 1

!

router rip

version 2

network 206.0.0.0

no auto-summary

!

router bgp 333333

no synchronization

bgp log-neighbor-changes

network 206.xxx.xxx.0

neighbor 69.xxx.xxx.xxx remote-as 11111

neighbor 69.xxx.xxx.xxx ebgp-multihop 3

neighbor 69.xxx.xxx.xxx timers 10 30

neighbor 69.xxx.xxx.xxx password 7 xxxxxxxxxxx

neighbor 69.xxx.xxx.xxx filter-list 2 in

neighbor 69.xxx.xxx.xxx filter-list 3 out

neighbor 144.xxx.xxx.xxx remote-as 22222

neighbor 144.xxx.xxx.xxx timers 10 30

neighbor 144.xxx.xxx.xxx filter-list 1 in

neighbor 144.xxx.xxx.xxx filter-list 3 out

no auto-summary

!

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 Multilink1

ip route 69.xxx.xxx.xxx 255.255.255.255 69.xxx.xxx.xxx

!

ip as-path access-list 1 permit ^1239_[0-9]*$

ip as-path access-list 2 permit ^32654_[0-9]*$

ip as-path access-list 3 permit ^$

!

ip any any log

no cdp run

8 REPLIES
Community Member

Re: Turn off BGP load balancing

The simplest way to have all the traffic go via only 1 link is to give a higher weight for that particular neighbor.

neighbor x.x.x.x weight

Since weight is the attribute that bgp refers 1st, the routes with higher weight will be preferred. Thanks!

Best Regards,

Manoj

Community Member

Re: Turn off BGP load balancing

Add the weight to both providers and removed

default routes. Looks like it's working.

Thanks

Community Member

Re: Turn off BGP load balancing

Hi,

There are filter-lists for incoming routing updates for both the neighbors, hence assuming that, for those filterd n/ws, the traffic will go out on that provider's link.

For the rest of the o/g traffic, there is a default route to Mu1, config another one with higher AD (floating static) pointing to other provider.. This will work as fail over for o/g traffic.

For incoming traffic, u can take help of AS path attribute to advt ur n/w to both the providers with diff length of AS-path, this will make i/c traffic come from ur desired provider..and also provide failover thro' the other provider as backup path.

Rgds,

Dhiren Shah

Re: Turn off BGP load balancing

HI, [PLS RATE if HELPS]

Add weight attribute to the Primary Link and it should be preferred always.

For the failover, use the floating static routes. Add more AD value to the secondary Link, so whenever the Primary fails the Secondary is always there in the Global Routing table with Higher AD is preferred.

When the Primary is restored, the BGP with more Weight value is trigerred in the Routing table, Since the AD of BGP will be "20" and the fall-back to primary will occur.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

Community Member

Re: Turn off BGP load balancing

Add the weight to both AS neighbor,now all out put is going out Fastethernet 0/0 and all input is comming multillink1.Is only one provider sending updates, or is there somthing I am missing. her is the show ip bgp

Network Next Hop Metric LocPrf Weight Path

*> 0.0.0.0 69.x.x.x 0 200 11111 i

*> 8.3.52.0/23 144.x.x.x 561 20 22222 26759 i

*> 8.3.213.0/24 144.x.x.x 561 20 22222 4739 i

*> 8.8.9.0/24 144.x.x.x 561 20 22222 27646 ?

*> 8.8.128.0/21 144.x.x.x 245 20 22222 14135 i

*> 8.10.162.0/24 144.x.x.x 561 20 22222 19181 i

*> 8.11.251.0/24 144.x.x.x 210 20 22222 14236 i

*> 8.12.72.0/22 144.x.x.x 170 20 22222 13767 i

*> 12.0.18.0/24 144.x.x.x 210 20 22222 27585 i

*> 12.0.239.0/24 144.x.x.x 229 20 22222 33628 i

*> 12.2.46.0/24 144.x.x.x 193 20 22222 22492 i

*> 12.2.142.0/24 144.x.x.x 8 20 22222 14381 i

*> 12.3.33.0/24 144.x.x.x 230 20 22222 17033 i

*> 12.4.96.0/24 144.x.x.x 210 20 22222 14452 i

*> 12.4.96.0/23 144.x.x.x 210 20 22222 14452 i

*> 12.4.97.0/24 144.x.x.x 210 20 22222 14452 i

*> 12.5.96.0/24 144.x.x.x 171 20 22222 6988 i

*> 12.9.194.0/23 144.x.x.x 560 20 22222 32012 i

*> 12.9.196.0/22 144.x.x.x 560 20 22222 32012 i

*> 12.14.172.0/23 144.x.x.x 171 20 22222 29960 i

Re: Turn off BGP load balancing

Hi,

One Question Here: what is the objective of configuring a default route here? you router will always prefer the Default route over the BGP, since you are running BGP, you dont need a default route

You could just configure the (Weight) or (local prefrence) to influence your outgoing path.

As for the incoming traffic, Since you have different Service providers, you would configure As-Path prepending so that incoming traffic will prefer your desired SP.

HTH

Mohamed

Community Member

Re: Turn off BGP load balancing

Hi,

The default route will be in action for the networks not learned from the bgp peers, it will not override the bgp learned prefixes. If the bgp peers are sending default route in bgp(which may not be the case here), then static default route is not reqd.

Rgds,

Dhiren

Silver

Re: Turn off BGP load balancing

For this set-up, couldn't you use static routes to do the same thing?

ip route 0.0.0.0 0.0.0.0

ip route 0.0.0.0 0.0.0.0 100

This way the routes are tied to the interface, if the interface goes down on the primary link all routes will go out the secondary link. When thr primary comes back up it will assume primary role. This might provide faster convergence for you too.

250
Views
8
Helpful
8
Replies
CreatePlease to create content