Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Two Cisco routers using EIGRP and the same won't exchange routing updates

I have 2 cisco routers (2621 IOS 12.2(5), 2821 IOS 12.4.7) that are connected to the same LAN segment. Both routers are running IP routing via EIGRP. both EIGRP processes are suing the same AS (100). (this config is a transitional one as we move fropm the 2621 to the 2821).

The issue is that the 2821 does not receive routing updates from the 2621. It does not even see the 2621 as an EIGRP neighbor. Mean while the 2621 does see the 2821 as a neighbor.

The two routers can see each other, and if I set a static default route on the 2821 I can route out from the 2821 to anywhere\any network on the rest of the WAN network.

A brief layout of the connections:

[Active WAN] -- [S0/0.1 (2621) FE 0/0.1] -- [FE 0/1 Trunk Cat2950 switch FE 0/4 Trunk] -- [GE 0/0.1 (2821) S 0/0/0.200] -- [Furture WAN]

Both both interfaces on the routers are configured to be on Native VLAN 1 using dot1q encapsulation.

I have used this configuration at several other sites as a transitional with any issues. So I'm either to close to the problem and am being blind or something weird is going on. :)

The router configurations are:

----2621

interface FastEthernet0/0

no ip address

speed 100

full-duplex

no mop enabled

!

interface FastEthernet0/0.1

description VLAN-1 PMI General Network

encapsulation dot1Q 1 native

ip address 172.16.31.1 255.255.255.128

ip pim sparse-dense-mode

ip cgmp

!

interface Serial0/0

description WAN Connections

no ip address

no ip proxy-arp

encapsulation frame-relay IETF

logging event subif-link-status

logging event dlci-status-change

no fair-queue

!

interface Serial0/0.1 multipoint

description Frame-Relay PMI-LTN 256 kb Primary

bandwidth 256

ip address 172.16.20.130 255.255.255.252

ip pim sparse-dense-mode

cdp enable

frame-relay map ip 172.16.20.129 308 broadcast

router eigrp 100

network 172.16.0.0

network 172.17.0.0

network 172.18.0.0

no auto-summary

eigrp log-neighbor-changes

!

ip classless

--- 2821

interface GigabitEthernet0/0

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.31.4 255.255.255.128

no snmp trap link-status

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

encapsulation frame-relay IETF

!

interface Serial0/0/0.200 point-to-point

ip address aa.bb.cc.dd 255.255.255.252

frame-relay interface-dlci 200 IETF

!

router eigrp 100

network 172.16.0.0

no auto-summary

Some information from the 2821 router:

PMI-2821-1#sh ip eigrp traff

IP-EIGRP Traffic Statistics for AS 100

Hellos sent/received: 3251/0

Updates sent/received: 0/3100

Queries sent/received: 0/0

Replies sent/received: 0/0

Acks sent/received: 0/0

Input queue high water mark 1, 0 drops

SIA-Queries sent/received: 0/0

SIA-Replies sent/received: 0/0

Hello Process ID: 210

PDM Process ID: 208

5 REPLIES

Re: Two Cisco routers using EIGRP and the same won't exchange ro

Hello just for your information:

most common causes of problems with EIGRP neighbor relationships:

l Unidirectional link

l Uncommon subnet, primary, and secondary address mismatch

l Mismatched masks

l K value mismatches

l Mismatched AS numbers

l Stuck in active

l Layer 2 problem

l Access list denying multicast packets

l Manual change (summary router, metric change, route filter)

do you see hello packets coming from each neighbor on the ethernet interfaces?

debug ip eigrp packet hello

If you ping 224.0.0.10 what do you see? this will check multicast on this segment.

Let us know,

Vlad

New Member

Re: Two Cisco routers using EIGRP and the same won't exchange ro

The result of the ping 224.0.0.10 on the 2821 router:

PMI-2821-1#ping 224.0.0.10

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.10, timeout is 2 seconds:

Reply to request 0 from pmi-2621-1-fe0-0-1.alteontraining.com (172.16.31.1), 1 ms

The output from a sh ip eigrp traffic on the 2821 router:

IP-EIGRP Traffic Statistics for AS 100

Hellos sent/received: 4702/0

Updates sent/received: 0/4478

Queries sent/received: 0/0

Replies sent/received: 0/0

Acks sent/received: 0/0

Input queue high water mark 1, 0 drops

SIA-Queries sent/received: 0/0

SIA-Replies sent/received: 0/0

Hello Process ID: 210

PDM Process ID: 208

The output from a sh ip eigrp traffic on the 2621 router:

IP-EIGRP Traffic Statistics for process 100

Hellos sent/received: 609116/106544

Updates sent/received: 94243/112

Queries sent/received: 121/68

Replies sent/received: 67/68

Acks sent/received: 229/226

Input queue high water mark 2, 0 drops

SIA-Queries sent/received: 0/0

SIA-Replies sent/received: 0/0

Results for debug EIGRP packet hello and EIGRP neighbor (2821 router):

*Jun 8 01:08:27.978: EIGRP: Sending HELLO on GigabitEthernet0/0.1

*Jun 8 01:08:27.978: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Jun 8 01:08:29.974: EIGRP: Neighbor(172.16.31.1) not yet found

Results for debug EIGRP packet hello and EIGRP neighbor (2621 router):

5d07h: EIGRP: Sending HELLO on FastEthernet0/0.1

5d07h: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 all

5d07h: EIGRP: Sending HELLO on FastEthernet0/0.2

5d07h: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

5d07h: EIGRP: Sending HELLO on FastEthernet0/0.4

5d07h: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

5d07h: EIGRP: Received HELLO on FastEthernet0/0.1 nbr 172.16.31.4

5d07h: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/7

The are also the following console messages being displayed on the 2621 router:

5d07h: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 172.16.31.4 (FastEthernet0/0.1) is up: new adjacency

PMI-2621-1#

5d07h: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 172.16.31.4 (FastEthernet0/0.1) is down: retry limit exceeded

The 2821 router was originally misconfigured with a bad stbnet mask, but that has ben fixed. Both routers have been restarted since the fix mas made just in cast there was something stuck i memory causing the problem.

Re: Two Cisco routers using EIGRP and the same won't exchange ro

I believe that for some reason the hellos from 2621 are not reaching 2821 router.

could you please recheck the ping 224.0.0.10 from 2601, check if you get a response from 2821.

Let me know,

Vlad

Silver

Re: Two Cisco routers using EIGRP and the same won't exchange ro

I agree with you about the hellos. Do you have any multicast config on the 2950 switch? These could be blocking the hellos from reaching the 2821. Note that hellos are multicasted.

Also try to remove the CGMP config on the interface and see what happens.

New Member

Re: Two Cisco routers using EIGRP and the same won't exchange ro

Thanks guys. I resolved the problem.

Following olorunloba's advice I removed the cgmp statment from the interface, but the problem persisted. Then I removed the the "ip pim sparse-dense-mode" statment. Either removing that statment or removing the combination appears to have resolved the issue.

I am now getting routing updates to the 2821 router.

thanks for your help.

1147
Views
8
Helpful
5
Replies
CreatePlease to create content