Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Two internet access on ospf network

Good day,

I have to configure two internets access point in ospf network.I don't need if it is necessary to have 2 bacbone area, or if it can be done with a single backbone area.Is it necessary to configure pbr ??

Any suggest will be appreciated.

Regards

3 REPLIES

Re: Two internet access on ospf network

Hello,

what you can do is to insert one default route from each internet gateway. Depending on the metric and type of external route created you will even achieve load sharing or primary/backup scenarios.

In any case you will only need one area 0 (backbone area). In fact OSPF doesn´t operate properly, if you have two disconnected backbone areas.

An example config for your case could look like this:

ISPgw1 (primary):

interface Serial0

description to ISP1

ip address 10.1.1.2 255.255.255.252

ip route 0.0.0.0 0.0.0.0 Serial0

!

router ospf 10

default-information originate

ISPgw2 (backup):

interface Serial0

description to ISP2

ip address 10.2.2.2 255.255.255.252

ip route 0.0.0.0 0.0.0.0 Serial0 250

!

router ospf 10

default-information originate

The administrative distance on the static default to ISP2 makes sure, that it will not be in the IP routing table as long as the primary router ISPgw1 announces the default through OSPF. And as ISPgw2 has no static default route it will not announce a default itself. Once ISPgw1 withdraws the default route, because Serial0 is down, the static default on ISPgw2 will be insertad into the routing table and therefore ISPgw2 will announce a default through OSPF.

This is a primary/backup case. By not configuring the AD of 250 on the static default in ISPgw2 you can achieve load sharing.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Two internet access on ospf network

escuse me my e-mail wasn't clear.I'll add some information.

There is architecture:

ISP2

|

ISP1--AREA1--AREA0--AREA2--AREA3

Router of AREA1 AND AREA 3 are not in same town.The person who are in AREA 3 take internet directly to ISP2 and the person which are in AREA 1 take internet diretcly in ISP1.

Escume me again for doesn't put more detail in my e-mail

Regards.

Re: Two internet access on ospf network

Hello,

the config would then look like this:

ISPgw1:

interface Serial0

description to ISP1

ip address 10.1.1.2 255.255.255.252

ip route 0.0.0.0 0.0.0.0 Serial0

!

router ospf 10

default-information originate metric-type 1

ISPgw2 (backup):

interface Serial0

description to ISP2

ip address 10.2.2.2 255.255.255.252

ip route 0.0.0.0 0.0.0.0 Serial0

!

router ospf 10

default-information originate metric-type 1

Metric Type 1 will cause the metric to reflect the cost to reach the respective ISPgw, i.e. the closest exit to the internet will be choosen. This should fulfill your requirements.

Hope this helps! please rate all posts.

Regards, Martin

102
Views
5
Helpful
3
Replies