cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
314
Views
0
Helpful
1
Replies

Two ISP DSL connections, Nat, Routing based on source address

mueller
Level 1
Level 1

Hello,

we have a 1812 connected to two ISPs with PPPoE.

dialer0 has static IPs, dialer1 has IP negotiated.

Inside we have

vlan1: 10.0.10.0/24

vlan2: 10.0.11.0/24

vlan3: 10.0.0.0/24

At the moment 10.0.11.10 has static nat:

ip nat inside source static 10.0.11.10 79.140.54.10

and all other internal IPs are dynamic nat:

access-list 105 deny ip 10.0.10.0 0.0.0.255 10.0.250.0 0.0.1.255

access-list 105 deny ip 10.0.0.0 0.0.0.255 10.0.250.0 0.0.1.255

access-list 105 deny ip 10.0.11.0 0.0.0.255 10.0.250.0 0.0.1.255

access-list 105 permit ip 10.0.10.0 0.0.0.255 any

access-list 105 permit ip 10.0.11.0 0.0.0.255 any

access-list 105 permit ip 10.0.0.0 0.0.0.255 any

ip nat inside source list 105 interface Dialer0 overload

Now I want:

vlan1 -> dynamic nat dialer0

vlan2 -> dynamic nat dialer0

vlan3 -> dynamic nat dialer1

I've tried to set an access-list and

ip nat inside source list 106 interface Dialer1 overload

for the vlan3 IP's. The packets where nat'ed correctly, but sent out on dialer0. So the incoming replys on dialer1 are dropped by access-list cause the "ip inspect bla out" on dialer1 did not know the packets.

So how can I route packets from vlan3 after nat through dialer1?

thanks

carsten

1 Accepted Solution

Accepted Solutions

paolo bevilacqua
Hall of Fame
Hall of Fame

Hi,

you need policy routing for that:

route-map to-isp

match ip address 106

set interface dialer1

interface vlan3

ip policy route-map to-isp

Hope this helps, please rate post if it does!

View solution in original post

1 Reply 1

paolo bevilacqua
Hall of Fame
Hall of Fame

Hi,

you need policy routing for that:

route-map to-isp

match ip address 106

set interface dialer1

interface vlan3

ip policy route-map to-isp

Hope this helps, please rate post if it does!

Review Cisco Networking products for a $25 gift card