Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Two links with two Routers to one ISP

Dear

I have two links from one ISP and it is terminating on two Routers. How can I configure redundancy with BGP. If one router goes down the other one have to send the traffic. One of the links is Active and the other one is standby.

3 REPLIES
New Member

Re: Two links with two Routers to one ISP

Dear Ali,

Primary Router:

interface FastEthernet0/0
description secondaary router
ip address 10.10.1.1 255.255.255.0(Ip addresss for the 100 MB Ethet link on my primary router)
no ip redirects
duplex auto
speed auto
standby 1 ip 10.10.1.2
!
(This puts both routers interfaces in the same subnet, with a common standby group of 1 on that link. So both routers
are responsible for acting together as the virtual router 10.10.1.2 Hosts are configured with a static default gateway,
IP address that of the virtual router, 10.10.1.2 Virtual router)
!
standby 1 timers 5 15
standby 1 priority 110
standby 1 preempt
standby 1 authentication username
standby 1 track Ether Interface for 100 MB ckt (GE0/0) on this router

Secondar Router:

interface FastEthernet0/0
description secondaary router
ip address 10.10.1.3 255.255.255.0 (Ip addresss for the 100 MB Ethet link on my primary router)
no ip redirects
duplex auto
speed auto
standby 1 ip 10.10.1.2 (This puts both routers interfaces in the same subnet, with a common standby group of 1 on that link. So both routers
are responsible for acting together as the virtual router 10.10.1.2 Hosts are configured with a static default gateway,
IP address that of the virtual router, 10.10.1.2 Virtual router)
!
standby 1 timers 5 15
standby 1 priority 95
standby 1 preempt
standby 1 authentication username
standby 1 track Interface of the DS3 Circit on this router

HTH.

Vaib...

New Member

Re: Two links with two Routers to one ISP

Dear

In my case I have configured Vlan 630 for the fail over. Please see the configuration below. I need BGP confifuration for the redundancy to the ISP if the active Router fails.

Interface G7/1

Connect_To_Sec

switch port

switch port trunk allowed vlan 100,101,630

switch port mode tru


!

!

Interface G7/2

Connect_To_Sec

switch port

switch  port trunk allowed vlan 100,101,630

switch port mode tru

!

!

Interface vlan 630

ip add 172.16.3.1

stand 63 ip 172.16.3.3 (172.16.3.2 is secondary IP)

standby 63 preemt

Hall of Fame Super Gold

Re: Two links with two Routers to one ISP

Proper BGP configuration requres experience and cannot be done by end users, consequently I recommend you engnage a reputable consltant ot cerfied cisco partner.

672
Views
5
Helpful
3
Replies
CreatePlease to create content