Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to change my username and password on Cisco 2800

I have tried to change the username and password using the following procedure but when I do so and reboot the router and try to login using the new userid and password it says Authentication failed. What am I doing wrong?

Complete these steps in order to recover your password:

  1. Shut down the router.

  2. Remove the compact flash that is at the back of the router.

  3. Power on the router.

  4. Once the Rommon1> prompt appears, enter this command:

    confreg 0x2142
  5. Insert the compact flash.

  6. Type reset.

  7. When you are prompted to enter the initial configuration, type No, and press Enter.

  8. At the Router> prompt, type enable.

  9. At the Router# prompt, enter the configure memory command, and press Enter in order to copy the startup configuration to the running configuration.

  10. Use the config t command in order to enter global configuration mode.

  11. Use this command in order to create a new user name and password:

    router(config)#username cisco privilege 15 password
              cisco
  12. Use this command in order to change the boot statement:

    config-register
              0x2102
  13. Use this command in order to save the configuration:

    write
          memory
  14. Reload the router, and then use the new user name and password to log in to the router.

16 REPLIES
Purple

Unable to change my username and password on Cisco 2800

Hi,

At step nine copy the config and post here.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Unable to change my username and password on Cisco 2800

Current configuration : 3913 bytes

!

version 12.4

service timestamps debug datetime msec localtime show-timezone year

service timestamps log datetime msec localtime show-timezone year

service password-encryption

!

hostname TECH.SRST

!

boot-start-marker

boot-end-marker

!

logging buffered 16384 debugging

enable secret 5 $1$0rfp$3tUcm5rbW0rEGcu4MQlRz0

!

aaa new-model

!

!

aaa authentication login default group radius local line enable

aaa authentication enable default group radius enable line

aaa authorization console

aaa authorization exec default group radius local if-authenticated

aaa accounting suppress null-username

aaa accounting exec default start-stop group radius

aaa accounting system default start-stop group radius

!

aaa session-id common

clock timezone CST -6

clock summer-time CDT recurring

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

!

ip cef

!

!

no ip domain lookup

ip domain name hutto.txed.net

isdn switch-type primary-ni

!

!

trunk group  POTS

max-calls any 2

hunt-scheme sequential

!

--More--                           voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 reject /5555555555/

!

!

voice translation-profile BLOCK

translate calling 1

!

!

!

!

username calence privilege 15 secret 5 $1$iBGF$yYDT.QN1mTF7mENE3pyk7.

username admin privilege 15 secret 5 $1$jttL$6afcdsWpWGhmjPpz5DJyL0

username cisco privilege 15 password 7 110A1016141D

!

!

controller T1 0/0/0

framing esf

linecode b8zs

pri-group timeslots 1-24

description 60.IPZX.351598..CRTX

!

!

!

!

interface GigabitEthernet0/0

ip address 10.55.100.2 255.255.254.0

shutdown

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.55.100.2

!

interface GigabitEthernet0/1

--More--                            no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/3/0

no ip address

shutdown

no fair-queue

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.55.100.1

!

!

ip http server

--More--                           no ip http secure-server

!

snmp-server community R1v3rH0rs3 RW

snmp-server community H1PP0$ RO

!

!

radius-server host 10.55.55.32 auth-port 1645 acct-port 1646 key 7 132D02061F5C45390F

radius-server host 10.55.55.10 auth-port 1645 acct-port 1646 key 7 032C4E1F125F605F6A

!

control-plane

!

!

!

voice-port 0/0/0:23

translation-profile incoming BLOCK

!

voice-port 0/1/0

trunk-group POTS 1

description POTS line

!

voice-port 0/1/1

trunk-group POTS 5

description POTS line

!

voice-port 0/2/0

!

voice-port 0/2/1

!

!

!

!

!

dial-peer voice 911 pots

trunkgroup POTS

description *** Outbound 911 ***

destination-pattern 911

forward-digits 3

!

dial-peer voice 9911 pots

trunkgroup POTS

description *** Outbound 911 ***

destination-pattern 9911

forward-digits 3

!

dial-peer voice 50 voip

preference 10

destination-pattern 759....

modem passthrough nse codec g711ulaw

session target ipv4:10.55.100.5

incoming called-number .T

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

codec g711ulaw

!

dial-peer voice 51 voip

preference 1

destination-pattern 759....

modem passthrough nse codec g711ulaw

session target ipv4:10.200.100.5

incoming called-number .T

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

codec g711ulaw

!

dial-peer voice 11 pots

destination-pattern 1..........

fax rate voice

direct-inward-dial

port 0/0/0:23

forward-digits all

!

dial-peer voice 12 pots

preference 1

destination-pattern [2-9]......

fax rate voice

direct-inward-dial

port 0/0/0:23

forward-digits all

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.55.100.2 port 2000

max-ephones 50

max-dn 100

system message primary SRST - Fallback

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp clock-period 17180297

ntp update-calendar

ntp server 10.55.1.1

!

end

VIP Super Bronze

Unable to change my username and password on Cisco 2800

at step 13, can you try copy running-config startup-config

and not wr

http://www.cisco.com/en/US/products/hw/routers/ps259/products_password_recovery09186a0080094675.shtml

HTH

New Member

Unable to change my username and password on Cisco 2800

did not work using the copy running-config startup-config.   Sometimes it looks like it takes the username and password and I get a display that looks like this.

TECH.SRST con0 is now available

Press Ret to get Started

When I hit return it goes back to

User Access Verification

Username:

Purple

Unable to change my username and password on Cisco 2800

Hi,

the username/password was saved correctly and if you can't contact radius server you should fall back to local user/password so that's strange.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Unable to change my username and password on Cisco 2800

Since this is not working, is it possibe to save my Configuration on this router, by copying the running config to a notepad and resetting the router to factory default and pasting the config back?  If not what is the best option if I cannot login into it.

Purple

Unable to change my username and password on Cisco 2800

Hi,

yes you can do that.Don't forget you'll have to no shut all the interfaces.

Regards.

Alain

Don't forget to rate helpful posts.

Unable to change my username and password on Cisco 2800

username calence privilege 15 secret 5 $1$iBGF$yYDT.QN1mTF7mENE3pyk7.

username admin privilege 15 secret 5 $1$jttL$6afcdsWpWGhmjPpz5DJyL0

username cisco privilege 15 password 7 110A1016141D

According to step 9 you do the following.

At the Router# prompt, enter the configure memory command, and press Enter in order to copy the startup configuration to the running configuration.

When, Cadet had you paste the configuration, I noticed that besides the cisco username there was an admin account and

a calence account? Are you able to log in with any of those?

New Member

Unable to change my username and password on Cisco 2800

I tried all of these, the last time someone tried to login was couple of years ago, and that person is gone.  The router has been working with no problems and it was when i tried to login to check the configuration that I found no one knew the passwords.

Unable to change my username and password on Cisco 2800

Does the router still have communication with the Radius server?

New Member

Unable to change my username and password on Cisco 2800

I have found the problem.  It was the radius statements.  I deleted the radius statements and used the username and password command and it worked this time.  When I finish working on my T1 issue, I will work on the Radius.  Thanks for all your help

Unable to change my username and password on Cisco 2800

Yeah, that's why I was asking about the Radius communication. From looking at the configuration I noticed that

radius was listed before local and line, so if there was still communication between the router and the Radius server

it should still be using radius. Let us know if it worked.

Purple

Unable to change my username and password on Cisco 2800

Hi,

that's why I found it strange because all the interfaces were in shutdown state so he shouldn't communicate with the radius server and fallback to local database.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Unable to change my username and password on Cisco 2800

I have a question.  when I put my Radius statements back in should they follow the local username and password or does it matter.

Unable to change my username and password on Cisco 2800

It should only b.in the aaa config

Unable to change my username and password on Cisco 2800

Cadet u bring up a damn good point btw.... Weird huh?

2990
Views
0
Helpful
16
Replies
CreatePlease to create content