Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

unable to connect to neighboring switch with interface vlan

I am sitting on switch A-

I can see switch B with a

show cdp neigh

Device ID: Switch

Entry address(es):

IP address: 172.20.111.202

Interface: GigabitEthernet2/0/18, Port ID (outgoing port): GigabitEthernet2/0/

3

I have trunking enabled to allow all vlans

Port Vlans allowed on trunk

Gi1/0/18 1-4094

Gi1/0/50 110-111

Gi1/0/51 151-152

Gi1/0/52 151-152

Gi2/0/18 1-4094

Gi2/0/50 110-111

Gi2/0/51 151-152

Gi2/0/52 151-152

Port Vlans allowed and active in management domain

Gi1/0/18 1,50,110-111,150-153

Gi1/0/50 110-111

Port Vlans allowed and active in management domain

Gi1/0/51 151-152

Gi1/0/52 151-152

Gi2/0/18 1,50,110-111,150-153

Gi2/0/50 110-111

Gi2/0/51 151-152

Gi2/0/52 151-152

and have configured a vlan 111 with an IP address..here is some of the config of switch B

Building configuration...

subnet-zero !

!

!

!

!

!

!

interface FastEthernet0

no ip address

shutdown

!

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface TenGigabitEthernet1/0/1

!

interface TenGigabitEthernet1/0/2

!

111

spanning-tree portfast

!

interface GigabitEthernet2/0/19

switchport access vlan 111

!

interface GigabitEthernet2/0/20

!

interface GigabitEthernet2/0/21

!

interface GigabitEthernet2/0/22

!

interface GigabitEthernet2/0/23------------

switchport mode trunk

!

interface GigabitEthernet2/0/24

!

interface GigabitEthernet2/0/25

switchport access vlan 811

!

interface GigabitEthernet2/0/26

switchport access vlan 111

!

interface TenGigabitEthernet2/0/1

!

interface TenGigabitEthernet2/0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan111---------------------------

ip address 172.20.111.202 255.255.255.0 !

interface Vlan811

ip address 192.168.100.10 255.255.255.0 !

ip classless

ip http server

!

!

control-plane

!

!

But i cannot ping or telnet from switch A which is directly connected to switch B

via trunk

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Just to follow up on last post.

You can either

1) have vlan 111 interface on 3120 and use default-gateway of CSS IP address in 172.20.111.x subnet

or

2) have vlan 110 interface on 3120 and use default-gateway of CSS IP address in 172.20.110.x subnet.

Jon

17 REPLIES
Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Need some more info -

1) what type of switches are these ?

2) Can you post "sh ip int brief" from both switches

3) do you have a L3 vlan interface for 111 on switch A ?

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

switch A is a stacked 3750

switch B are stacked 3120's (hp blade enclosure)

My guy in the field just told me

he could ping 172.20.111.1 from

switch B!?!?!

here is the sh ip int brief from switch A

with ip's

switch A#sh ip int br

Interface IP-Address OK? Method Status Protocol

Vlan1 unassigned YES NVRAM up up

Vlan110 172.20.110.4 YES NVRAM up up

Vlan111 unassigned YES manual up up

Im working on getting it for b

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Vlan111 unassigned YES manual up up

You don't have an IP address assigned to vlan 111 interface on switch A. Assign an IP address out of the 172.20.111.x subnet and set this to be the default-gateway on the 3120. So

3750

int vlan 111

ip address 172.20.111.x where x is a free IP address out of that subnet

3120

ip default-gateway 172.20.111.x where x is the IP address on 3750.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

Whats weird is that I can Ping a server

that is sitting on the switch itself

but can not ping a vlain int on the switch

Ping to server

SWITCH A#ping 172.20.111.100

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.111.100, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Ping to switch B

Switch A#ping 172.20.111.202

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.111.202, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Can you post info asked for and in addition can you post a "sh ip route" from both switches.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

switch A # sh ip route

Default gateway is 172.20.110.1

Host Gateway Last Use Total Uses Interface

ICMP redirect cache is empty

Ill ask for the default IP route to switch B

But i dont recall configuring one..

I was under the impression the default routes are not alway necessary on switches

switch A is a stacked 3750

switch B are stacked 3120's (hp blade enclosure)

My guy in the field just told me

he could ping 172.20.111.1 from

switch B!?!?!

here is the sh ip int brief from switch A

with ip's

switch A#sh ip int br

Interface IP-Address OK? Method Status Protocol

Vlan1 unassigned YES NVRAM up up

Vlan110 172.20.110.4 YES NVRAM up up

Vlan111 unassigned YES manual up up

Im working on getting it for b

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Ignore previous post.

What is 172.20.111.1 ?

Is the 3750 meant to be a L2 switch only ?

If so you will need to give the 3120 a L3 vlan interface in vlan 110 and not vlan 111.

Can you confirm what is the 3750 meant to be doing and where is the inter-vlan routing happening.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

111.1 is actually the gateway we are using for the server.

It is actually a CSS load balancer

I do believe the 3750 is only to be acting as a L2 device.

All it has are servers hanging off of it.

This is the first switch we are connecting to one of its interfaces

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

If the 3750 is only L2 then you will need to give the 3120 a L3 vlan inteface in vlan 110. This doesn't mean you can't have ports and servers in vlan 111, on a L2 switch the L3 vlan interface is only used to manage the switch.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

hmm...we have the server which is assigned to vlan 111 with the ip 172.20.111.100

The server itself is accessible and pingable

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Okay then if you can ping 172.20.111.100 from the 3750 then what have you set the default-gateway to on the 3120 ?

And what is the default-gateway for the server 172.20.111.100 ?

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

Hi Jon

the default gw.for the server is 172.20.111.1

I can ping the server from the default GW

(the css load balancer)

Well it looks like i did have to assign

a vlan 110 ip interface to gain access

to the switch.

Whats weird now..is that i can ping

111.100 from Switch A

But i can not ping it from switch B...and

this is where its connected

will this be resolved if i assigned a default gw to the 3120?

I havent assigned one yet.

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

You need a default-gateway on switch B to ping anything outside of the subnet assigned to switch B's vlan interface.

So if you want to ping 172.20.111.100 from switch B and switch B is in the 172.20.110.x subnet then yes you will need to add a default-gateway to the 3120.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

OK..

so i assigned the default gateway of the switch to the same as the server

172.20.111.1

unpingable from switch B

I changed the default gateway to the same

as switch A

172.20.110.1

and the server is pingable from switch B

Just seems odd that the server works fine

with a default gw that doesnt work on switch B..a switch it is directly connected to

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

server is in vlan 111 with a default-gateway of 172.20.111.1 ?

If you allocate a vlan 110 interface on switch B then you have to use a default-gateway out of the vlan 110 subnet. You cannot use the same default-gateway as the server.

You could create a vlan 111 interface instead on the 3120 switch and then use the server default-gateway - see previous post.

Jon

Hall of Fame Super Blue

Re: unable to connect to neighboring switch with interface vlan

Richard

Just to follow up on last post.

You can either

1) have vlan 111 interface on 3120 and use default-gateway of CSS IP address in 172.20.111.x subnet

or

2) have vlan 110 interface on 3120 and use default-gateway of CSS IP address in 172.20.110.x subnet.

Jon

New Member

Re: unable to connect to neighboring switch with interface vlan

great this is starting to make alot more sense...thx!!

322
Views
0
Helpful
17
Replies