Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

unable to get DHCP address on WAN interface C2621

Dear All,

anyone can help with the issue?

I have read a lot and tried everything and nothing seems to solve the issue.

I have a C2621 where with the default config (after reload no initial config taken) aftert an erase nvram.

so the router is literally blank.

here is the config:

=======================================================================================================

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip http server

ip classless

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

!

!

end

=======================================================================================================

Only Thing modified is the ip address dhcp on fa 0/0.

no IP address is assigned to the interface.

the modem I use... have to use is a Cisco EPC3925 ( from the ISP (UPC) ) in bridge mode.

If I put any Win 7 or whatever PC on to that modems one of the 4 fa interfaces they get an ip.

the debug output from dhcp:

=======================================================================================================

Router(config-if)#no shut

Router(config-if)#

*Mar  1 00:01:52.767: DHCP: DHCP client process started: 10

*Mar  1 00:01:52.767: RAC: Delaying starting DHCP because interface FastEthernet0/0 not up

*Mar  1 00:01:54.759: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

Router(config-if)#

*Mar  1 00:03:19.847: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

*Mar  1 00:03:19.847: DHCP: DHCP client process started: 10

*Mar  1 00:03:19.847: RAC: Starting DHCP discover on FastEthernet0/0

*Mar  1 00:03:19.847: DHCP: Try 1 to acquire address for FastEthernet0/0

*Mar  1 00:03:22.351: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x26DD29B9

*Mar  1 00:03:24.871: DHCP: allocate request

*Mar  1 00:03:24.871: DHCP: new entry. add to queue

*Mar  1 00:03:24.871: DHCP: SDiscover attempt # 1 for entry:

*Mar  1 00:03:24.871: DHCP: SDiscover: sending 298 byte length DHCP packet

*Mar  1 00:03:24.871: DHCP: SDiscover 298 bytes

*Mar  1 00:03:24.871:             B'cast on FastEthernet0/0 interface from 0.0.0.0

*Mar  1 00:03:25.147: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x83145218

*Mar  1 00:03:25.307: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0xFE4183EB

*Mar  1 00:03:26.027: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x83145218

*Mar  1 00:03:27.427: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0xAA3768E3

*Mar  1 00:03:27.871: DHCP: SDiscover attempt # 2 for entry:

*Mar  1 00:03:27.871: DHCP: SDiscover: sending 298 byte length DHCP packet

*Mar  1 00:03:27.871: DHCP: SDiscover 298 bytes

*Mar  1 00:03:27.871:             B'cast on FastEthernet0/0 interface from 0.0.0.0

*Mar  1 00:03:30.111: DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x1BC6120C

*Mar  1 00:03:30.871: DHCP: SDiscover attempt # 3 for entry:

*Mar  1 00:03:30.871: DHCP: SDiscover: sending 298 byte length DHCP packet

*Mar  1 00:03:30.871: DHCP: SDiscover 298 bytes

*Mar  1 00:03:30.871:             B'cast on FastEthernet0/0 interface from 0.0.0.0

=======================================================================================================

SDiscover attempt # 3 for entry: stops and retries after 60 sec.

possible causes so far, that cannot be the cause

no access list is blocking udp traffic (blank config)

no Layer 1 issues (tried several cables which all work elswhere fine.),

bootp protocol may mess things up --- ip dhcp bootp ignore --- the same.

set the MAC to something else (dlink router or so.), no use

if the EPC3925 is not in bridging mode and is the DHCP Server the same applies.

the wonder of all is, my brother has a Dlink router and if I plug in the router's (2621) fa 0/0 to one of the Dlinks ports guess what happens?

any help idea (even if it is to change the ISP) is appreciated.

Than you all in advance!


Everyone's tags (4)
9 REPLIES

Re: unable to get DHCP address on WAN interface C2621

Have you tried port 0/1 on the 2621?

Sent from Cisco Technical Support iPad App

New Member

Re: unable to get DHCP address on WAN interface C2621

Thank you Jeff for your reply,

I just tried it and it is the same. if I use the EPC3925 as DHCP no BOOTP packets are present, but still no dhcp address is leased, and this applies to both interfaces on the 2621.

Guess it is time to call the provider, as the error must be on their end...

Re: unable to get DHCP address on WAN interface C2621

Hello

Try using a crossover cable and reboot the modem.

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
New Member

Re: unable to get DHCP address on WAN interface C2621

Dear pdriver,

thank you for the suggestion, sonds silly, I do not know if have tried it or not will definitely do and see if that makes a difference, but the point is good, thank you again!

New Member

Re: unable to get DHCP address on WAN interface C2621

Nothing seems to help... a 2620XM as dhcp server leases an address, a dlink, whatever leases an address. only the ISP and the ISP's modem not... however if I set it up as 192.168.1.1 255.255.255.252 and the router is the x.2 and than I have my own subnet with double NAT... :S speed is somehow decreased to 1/2... according to the provider noone had the same issue... the 2620XM cannot get an ip also something with UPC devices vs cisco... funny is upc uses cisco gear... anyway thanks for the suggestions so far, I will try to find a solution, and I am also open for any other suggestions.

Re: unable to get DHCP address on WAN interface C2621

Manually configure the MAC address on the interface like below...

find the mac address of the interface from 'show interface fa0/0'

interface fa0/0

ip dhcp client-id hex XXXX.XXXX.XXXX <---- fa0/0 mac address in this format

ip dhcp client hostname Router

ip address dhcp

Let us know if this works.

hth.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
New Member

Re: unable to get DHCP address on WAN interface C2621

Dear Bilal,

Thank you for the suggestuin, unfortunately I cannot enter the command ip dhcp client-id hex.

I tried it via:

int fa 0/0

     mac-address xxxx.xxxx.xxxx

     ip address dhcp

but in such a case no debug output is shown, as nothing would happen.

If I remove the manually configured MAC the debug is the same, and no IP is given.

Purple

unable to get DHCP address on WAN interface C2621

Hi,

Can you try one of these 2 commands

under interface:

ip dhcp  client client-id f0/0

no ip add dhcp

ip add dhcp

or

-under interface:

no ip add dhcp

ip add dhcp client-id Fastethernet0/0

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

unable to get DHCP address on WAN interface C2621

If you configure a Cisco router as a DHCP client, it may use a weird client-id in its DHCP requests. Instead of using the interface MAC address as the client ID (as most workstations do), the client ID is the string 'cisco-dotted.mac.ascii-ifname' where the dotted.mac.ascii is the interface MAC address in ascii and the ifname is the short interface name.

The format may not be understood by the DHCP server so its just about getting your router to send the correct client-id in its request. Perhaps Alains suggestion will work. I know the hex one works but doesnt seem supported on your router.

hth

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
1072
Views
0
Helpful
9
Replies
CreatePlease login to create content