Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to Ping Serial Interfaces but both Up Up!

Hi there Experts just badly needed a wonderful help for my Home Lab issue as I'm about to give up. Couldn't get the two interfaces pingable. I have got R1 and R2 connected via DCE/DTE cross-over serial cable and have configs for both routers shown below:

R1#sh run

Building configuration...

Current configuration : 811 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname R1

!

boot bootstrap tftp c2500-i-l.121-27b_4.bin 255.255.255.255

enable secret 5 $1$mdza$1Tcbw2xIy1KQ8XQy1mcHk0

enable password 7 05000F0433

!

ip subnet-zero

no ip domain-lookup

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface Serial0

ip address 172.16.10.1 255.255.255.0

no keepalive

clockrate 64000

!

interface Serial1

ip address 172.16.11.1 255.255.255.0

no keepalive

clockrate 64000

!

interface BRI0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

R1#

R1#sh ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Ethernet0 192.168.1.1 YES NVRAM up up

Serial0 172.16.10.1 YES NVRAM up up

Serial1 172.16.11.1 YES NVRAM down down

R1#

R1#sh controllers s 0

HD unit 0, idb = 0x12797C, driver structure at 0x12DD08

buffer size 1524 HD unit 0, V.35 DCE cable, clockrate 64000

cpb = 0x2, eda = 0x4140, cda = 0x4000

RX ring with 16 entries at 0x4024000

00 bd_ptr=0x4000 pak=0x12F1F8 ds=0x4027FC4 status=80 pak_size=0

01 bd_ptr=0x4014 pak=0x12F44C ds=0x4028680 status=80 pak_size=0

02 bd_ptr=0x4028 pak=0x12F6A0 ds=0x4028D3C status=80 pak_size=0

03 bd_ptr=0x403C pak=0x12F8F4 ds=0x40293F8 status=80 pak_size=0

04 bd_ptr=0x4050 pak=0x12FB48 ds=0x4029AB4 status=80 pak_size=0

05 bd_ptr=0x4064 pak=0x12FD9C ds=0x402A170 status=80 pak_size=0

06 bd_ptr=0x4078 pak=0x12FFF0 ds=0x402A82C status=80 pak_size=0

07 bd_ptr=0x408C pak=0x130244 ds=0x402AEE8 status=80 pak_size=0

08 bd_ptr=0x40A0 pak=0x130498 ds=0x402B5A4 status=80 pak_size=0

09 bd_ptr=0x40B4 pak=0x1306EC ds=0x402BC60 status=80 pak_size=0

10 bd_ptr=0x40C8 pak=0x130940 ds=0x402C31C status=80 pak_size=0

11 bd_ptr=0x40DC pak=0x130B94 ds=0x402C9D8 status=80 pak_size=0

12 bd_ptr=0x40F0 pak=0x130DE8 ds=0x402D094 status=80 pak_size=0

13 bd_ptr=0x4104 pak=0x13103C ds=0x402D750 status=80 pak_size=0

14 bd_ptr=0x4118 pak=0x131290 ds=0x402DE0C status=80 pak_size=0

15 bd_ptr=0x412C pak=0x1314E4 ds=0x402E4C8 status=80 pak_size=0

16 bd_ptr=0x4140 pak=0x131738 ds=0x402EB84 status=80 pak_size=0

cpb = 0x2, eda = 0x4800, cda = 0x4800

TX ring with 1 entries at 0x4024800

00 bd_ptr=0x4800 pak=0x000000 ds=0x4047E98 status=80 pak_size=285

01 bd_ptr=0x4814 pak=0x000000 ds=0x4048C10 status=80 pak_size=285

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

0 residual bit errors

run out of characters will post the next configs on the next reply

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Unable to Ping Serial Interfaces but both Up Up!

Personally, I think you have a cable or interface problem. Do you have another cable you can try?

John

HTH, John *** Please rate all useful posts ***

Re: Unable to Ping Serial Interfaces but both Up Up!

I have a hard time believing that the interfaces are bad, and I would be more hard pressed to believe that it was a bad cable.

You could try to manually specify hdlc encapsulation under the interfaces on both routers. HDLC is the default without specifying, but it's a L2 protocol meaning that you should be able to connect the cable, see the Up/Up status without having an address on the interface as long as HDLC was communicating with the other end.

You could also try ppp encapsulation and see if they come up. (I've never done the ppp encapsulation on a DCE/DTE cable.)

HTH,

John

HTH, John *** Please rate all useful posts ***
23 REPLIES

Re: Unable to Ping Serial Interfaces but both Up Up!

First thing that jumps out is that you have the "no keepalive" listed under your serial interfaces. This will show the interface as "Up/Up" even if there's not a cable connected. Try putting the keepalive back on the interface, and then look at your interface status.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

thanks for the reply john really appreciated but when I tried changing back to default setting of keepalive my protocol went down:

R1#ping 172.16.10.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#int s0

R1(config-if)#keepalive 10

R1(config-if)#^Z

R1#wr

Building configuration...

[OK]

R1#sh ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Ethernet0 192.168.1.1 YES NVRAM up up

Serial0 172.16.10.1 YES NVRAM up down

Serial1 172.16.11.1 YES NVRAM down down

R1#

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

here's the new config:

R1#sh run

Building configuration...

Current configuration : 797 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname R1

!

boot bootstrap tftp c2500-i-l.121-27b_4.bin 255.255.255.255

enable secret 5 $1$mdza$1Tcbw2xIy1KQ8XQy1mcHk0

enable password 7 05000F0433

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface Serial0

ip address 172.16.10.1 255.255.255.0

clockrate 64000

!

interface Serial1

ip address 172.16.11.1 255.255.255.0

no keepalive

clockrate 64000

!

interface BRI0

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

ip classless

no ip http server

!

!

line con 0

password 7 094A420C01

login

line aux 0

line vty 0 4

password 7 00021F031C50020D1D

login

!

end

R1#

Hall of Fame Super Blue

Re: Unable to Ping Serial Interfaces but both Up Up!

Could you post R2 config ?

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

Router2 Config:

R2#sh run

Building configuration...

Current configuration : 784 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname R2

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$i3C0$BjvjJfuGppy/dhNIt/JKf1

enable password 7 01180F0F49

!

no aaa new-model

ip subnet-zero

!

!

!

!

!

interface Ethernet0

ip address 192.168.1.2 255.255.255.0

!

interface Serial0

ip address 172.16.10.2 255.255.255.0

!

interface Serial1

ip address 172.16.11.2 255.255.255.0

no keepalive

!

interface BRI0

no ip address

encapsulation hdlc

no ip route-cache

shutdown

!

no ip http server

ip classless

!

!

!

!

line con 0

password 7 14111E0E14

login

line aux 0

transport input all

line vty 0 4

password 7 094A420C010E1E1919

login

!

end

R2#

Re: Unable to Ping Serial Interfaces but both Up Up!

More than likely it's not recognizing the cable between the two devices. The no keepalive "hides" the problem. :)

Can you post "sh int s0" from both routers? I'm assuming that your S0 is also configured on the other router, and can you post the other routers config as well?

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

R1#

R1#

R1#

R1#sh int s0

Serial0 is up, line protocol is down

Hardware is HD64570

Internet address is 172.16.10.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

110 packets output, 12414 bytes, 0 underruns

0 output errors, 0 collisions, 25 interface resets

0 output buffer failures, 0 output buffers swapped out

60 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

R1#

R2#

R2#

R2#sh int s0

Serial0 is up, line protocol is down

Hardware is HD64570

Internet address is 172.16.10.2/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

122 packets output, 11686 bytes, 0 underruns

0 output errors, 0 collisions, 30 interface resets

0 output buffer failures, 0 output buffers swapped out

50 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

R2#

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

yeah this is weird but when I put the no keepalive command the interfaces will show Up Up. lolz.. this is weird though.

Anyone expertz experienced this kind of drama before?

Hall of Fame Super Silver

Re: Unable to Ping Serial Interfaces but both Up Up!

Hello Paul,

check cabling you may have connected the ports R1:ser0 to R2:ser1 and r1:ser1 to r2:ser0

this could explain why enabling keepalive on ser0s you see them going down because ser1s still have no keepalive on them

cable type should be correct :

DCD=up DSR=up DTR=up RTS=up CTS=up

Hope to help

Giuseppe

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

when I put all the keepalives back all of my serial interfaces went down:

R2#sh int s0

Serial0 is down, line protocol is down

Hardware is HD64570

Internet address is 172.16.10.2/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output 00:00:56, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

215 packets output, 13732 bytes, 0 underruns

0 output errors, 0 collisions, 63 interface resets

0 output buffer failures, 0 output buffers swapped out

113 carrier transitions

DCD=down DSR=down DTR=down RTS=down CTS=down

R2#sh int s1

Serial1 is down, line protocol is down

Hardware is HD64570

Internet address is 172.16.11.2/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=down RTS=down CTS=up

R2#sh ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Ethernet0 192.168.1.2 YES NVRAM up up

Serial0 172.16.10.2 YES NVRAM down down

Serial1 172.16.11.2 YES NVRAM down down

R2#

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

R1#sh int s0

Serial0 is down, line protocol is down

Hardware is HD64570

Internet address is 172.16.10.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output 00:04:27, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

206 packets output, 14526 bytes, 0 underruns

0 output errors, 0 collisions, 65 interface resets

0 output buffer failures, 0 output buffers swapped out

125 carrier transitions

DCD=up DSR=up DTR=down RTS=down CTS=up

R1#sh int s1

Serial1 is down, line protocol is down

Hardware is HD64570

Internet address is 172.16.11.1/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=down DSR=down DTR=down RTS=down CTS=down

R1#sh ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Ethernet0 192.168.1.1 YES NVRAM up up

Serial0 172.16.10.1 YES NVRAM down down

Serial1 172.16.11.1 YES NVRAM down down

R1#

Re: Unable to Ping Serial Interfaces but both Up Up!

No keepalives on the interface isn't causing your issue though. Have you tried moving the same cable to S1 interface to see if you exhibit the same issue? Giuseppe is correct in that maybe you have the cable crossed from S0 to S1 on the other router?

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

Hi John,

The cable connected only from R1 S0 to R2 S0 but I tried connecting from R1 S0 to R2 S1 and change R2 S1's Ip Address but still can't ping at all the status down down

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

And I tried put all the settings back from where it was like no keepalive, serial cable connected from r1s0 to r2s0, put all together back even the IP Address, sh ip int brief:

R2#sh ip int brief

Interface IP-Address OK? Method Status Protocol

BRI0 unassigned YES NVRAM administratively down down

BRI0:1 unassigned YES unset administratively down down

BRI0:2 unassigned YES unset administratively down down

Ethernet0 192.168.1.2 YES NVRAM up up

Serial0 172.16.10.2 YES NVRAM up up

Serial1 172.16.11.2 YES manual down down

R2#ping 172.16.10.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#

Still no luck.. c",)

Re: Unable to Ping Serial Interfaces but both Up Up!

Personally, I think you have a cable or interface problem. Do you have another cable you can try?

John

HTH, John *** Please rate all useful posts ***

Re: Unable to Ping Serial Interfaces but both Up Up!

Oh, another thing:

Can you post "sh controllers S0" from both routers?

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

R1#show controllers s 0

HD unit 0, idb = 0x12797C, driver structure at 0x12DD08

buffer size 1524 HD unit 0, V.35 DCE cable, clockrate 64000

cpb = 0x2, eda = 0x4014, cda = 0x4028

RX ring with 16 entries at 0x4024000

00 bd_ptr=0x4000 pak=0x1314E4 ds=0x402E4C8 status=80 pak_size=328

01 bd_ptr=0x4014 pak=0x12F1F8 ds=0x4027FC4 status=80 pak_size=328

02 bd_ptr=0x4028 pak=0x12F44C ds=0x4028680 status=80 pak_size=328

03 bd_ptr=0x403C pak=0x12EFA4 ds=0x4027908 status=80 pak_size=104

04 bd_ptr=0x4050 pak=0x12F6A0 ds=0x4028D3C status=80 pak_size=104

05 bd_ptr=0x4064 pak=0x12F8F4 ds=0x40293F8 status=80 pak_size=104

06 bd_ptr=0x4078 pak=0x12FB48 ds=0x4029AB4 status=80 pak_size=104

07 bd_ptr=0x408C pak=0x12FD9C ds=0x402A170 status=80 pak_size=104

08 bd_ptr=0x40A0 pak=0x12FFF0 ds=0x402A82C status=80 pak_size=328

09 bd_ptr=0x40B4 pak=0x130244 ds=0x402AEE8 status=80 pak_size=328

10 bd_ptr=0x40C8 pak=0x130498 ds=0x402B5A4 status=80 pak_size=328

11 bd_ptr=0x40DC pak=0x1306EC ds=0x402BC60 status=80 pak_size=328

12 bd_ptr=0x40F0 pak=0x130940 ds=0x402C31C status=80 pak_size=328

13 bd_ptr=0x4104 pak=0x130B94 ds=0x402C9D8 status=80 pak_size=328

14 bd_ptr=0x4118 pak=0x130DE8 ds=0x402D094 status=80 pak_size=328

15 bd_ptr=0x412C pak=0x13103C ds=0x402D750 status=80 pak_size=328

16 bd_ptr=0x4140 pak=0x131290 ds=0x402DE0C status=80 pak_size=328

cpb = 0x2, eda = 0x4800, cda = 0x4800

TX ring with 1 entries at 0x4024800

00 bd_ptr=0x4800 pak=0x000000 ds=0x4006140 status=80 pak_size=285

01 bd_ptr=0x4814 pak=0x000000 ds=0x40067FC status=80 pak_size=285

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

0 residual bit errors

R1#

R2#sh controllers s 0

HD unit 0, idb = 0x29F1D4, driver structure at 0x2A05F0

buffer size 1524 HD unit 0, V.35 DTE cable

cpb = 0xE2, eda = 0x4140, cda = 0x4000

RX ring with 16 entries at 0xE24000

00 bd_ptr=0x4000 pak=0x2C8578 ds=0xE27FC4 status=80 pak_size=0

01 bd_ptr=0x4014 pak=0x2C8860 ds=0xE28680 status=80 pak_size=0

02 bd_ptr=0x4028 pak=0x2C8B48 ds=0xE28D3C status=80 pak_size=0

03 bd_ptr=0x403C pak=0x2C8E30 ds=0xE293F8 status=80 pak_size=0

04 bd_ptr=0x4050 pak=0x2C9118 ds=0xE29AB4 status=80 pak_size=0

05 bd_ptr=0x4064 pak=0x2C9400 ds=0xE2A170 status=80 pak_size=0

06 bd_ptr=0x4078 pak=0x2C96E8 ds=0xE2A82C status=80 pak_size=0

07 bd_ptr=0x408C pak=0x2C99D0 ds=0xE2AEE8 status=80 pak_size=0

08 bd_ptr=0x40A0 pak=0x2C9CB8 ds=0xE2B5A4 status=80 pak_size=0

09 bd_ptr=0x40B4 pak=0x2C9FA0 ds=0xE2BC60 status=80 pak_size=0

10 bd_ptr=0x40C8 pak=0x2CA288 ds=0xE2C31C status=80 pak_size=0

11 bd_ptr=0x40DC pak=0x2CA570 ds=0xE2C9D8 status=80 pak_size=0

12 bd_ptr=0x40F0 pak=0x2CA858 ds=0xE2D094 status=80 pak_size=0

13 bd_ptr=0x4104 pak=0x2CAB40 ds=0xE2D750 status=80 pak_size=0

14 bd_ptr=0x4118 pak=0x2CAE28 ds=0xE2DE0C status=80 pak_size=0

15 bd_ptr=0x412C pak=0x2CB110 ds=0xE2E4C8 status=80 pak_size=0

16 bd_ptr=0x4140 pak=0x2CB3F8 ds=0xE2EB84 status=80 pak_size=0

cpb = 0xE2, eda = 0x4814, cda = 0x4814

TX ring with 1 entries at 0xE24800

00 bd_ptr=0x4800 pak=0x000000 ds=0xE4FA68 status=80 pak_size=328

01 bd_ptr=0x4814 pak=0x000000 ds=0xE4F3A0 status=80 pak_size=328

0 missed datagrams, 0 overruns

0 bad datagram encapsulations, 0 memory errors

0 transmitter underruns

0 residual bit errors

R2#

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

yeah I just bought a new one from ebay that still covered with see thru plastic thing but it was working before with my old one, when i put the new one to serial 1 of both routers and found out that still unable to ping both interfaces and tried to pull out the old cable from S0's and connect to S1's in and still no luck and when I'm about to plug the old cable back to S0's its unable to ping both interfaces now. :-((

New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

you reckon the serial interfaces on two routers are failing?

Re: Unable to Ping Serial Interfaces but both Up Up!

I have a hard time believing that the interfaces are bad, and I would be more hard pressed to believe that it was a bad cable.

You could try to manually specify hdlc encapsulation under the interfaces on both routers. HDLC is the default without specifying, but it's a L2 protocol meaning that you should be able to connect the cable, see the Up/Up status without having an address on the interface as long as HDLC was communicating with the other end.

You could also try ppp encapsulation and see if they come up. (I've never done the ppp encapsulation on a DCE/DTE cable.)

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

You were right john when i checked the rear panel of the router and see if there's anything wrong with the interfaces I have noticed that there's a few misalligned divider that's causing some female and male pins not to connect on both ends and what i did was i looked for a needle pin to fix it and when i plugged the cable in to both serial interfaces it works like i tried pinging the other router and it works but when i screwed it to make sure the it wont loose the connection again the issue went back again. There's nothing bent pins in crossover serial cable as I just bought it and it's brand new the causing of the problem is the freaking interfaces. My question now are these serial interfaces changeable? Can I purchase these anywhere else?

Re: Unable to Ping Serial Interfaces but both Up Up!

Unfortunately, AFAIK, you can't replace the interface without replacing the card. If these are 2500 series routers, the interfaces are built into the router (at least the two that I have are).

I'm glad you figured out what the problem was though; that can be frustrating. =)

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Unable to Ping Serial Interfaces but both Up Up!

Yeah those are 2503s and when I opened the box that has a faulty serial interface I saw that its built-into the motherboard so no chance to just replace the serial interface. Yeah it was so really frustrating you know what I did? I get a needle pin and I took off the broken divider on female port and re-alligned the pins inside with the needle and tried re-plugging the serial cables and it works finally hehehe.. McGyver yeah?

321
Views
0
Helpful
23
Replies
CreatePlease to create content