Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to take tftp

Hi any body can help me taking tftp when i tried to take tftp from some of my companies cisco 1700 series and one 3600 series routers i am geeting error like %Error opening tftp://server ip/file name(Timed out)

theese are routers are undergone some hardening also...i am attaching some configuration with this

Building configuration...

Current configuration : 3164 bytes

!

version 12.3

service tcp-keepalives-in

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

!

boot-start-marker

boot-end-marker

!

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

aaa new-model

!

!

aaa authentication login default local

aaa session-id common

ip subnet-zero

no ip source-route

ip cef

!

!

!

no ip bootp server

no ip domain lookup

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

speed auto

no cdp enable

!

interface BRI0/0

no ip address

shutdown

no cdp enable

!

interface Serial1/0

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

no ip mroute-cache

no fair-queue

!

interface Serial1/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

shutdown

no cdp enable

!

ip classless

no ip http server

!

no cdp run

banner motd ^C

!

line con 0

line aux 0

no exec

line vty 0 4

exec-timeout 1 0

!

!

end

can anybody help me out solving the issue...

4 REPLIES

Re: Unable to take tftp

which TFTP server you are using?

are you able to ping TFTP server IP from switch/router and vice-versa?

make sure you configure TFTP server to send and receive files.

make sure you have set correct permissions on the TFTP share where configs will be downloaded?

The config you have posted doesn't have any active IP address, so i don't think it is possible to download config to TFTP.

New Member

Re: Unable to take tftp

no i did not include ip address..in the configuration thats all...ip addresses are set for the interface and it is alive router..and i am using solarwinds tftp server. with that one I am able to take some of the other routers tftp , but not some...theese routers are gone hardening also....I doubt any hardening command causing the problem... i am able to ping tftp server to host and vice versa...

Re: Unable to take tftp

Hi,

Have you posted full config here? If the router has an access list which denies packets to/fro on port used for tftp (69), then you wouldnt be able to upload files using tftp. Modify the ACLs accordingly.

Also if the router is in the DMZ or secured network then access to a lot of ports would be restricted which would not allow you to tftp files.

Hope this helps...

Regards,

AbhisheK

Please rate all helpful posts!!!

New Member

Re: Unable to take tftp

might be the firewall will be the problem....theese routers behind firewall zone....thanks for that info....

111
Views
0
Helpful
4
Replies
CreatePlease login to create content