Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to telnet

hi,

i  have a cisco  router and has a single public IP configured on one of  giga port .And have a server on LAN  whose  IP  i have static nat to  public IP on port 3389 for remote access to server which is  successful.But i am not able to telnet router on public IP configured .

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Unable to telnet

Hi,

no access-list 101

access-list 99 permit 192.168.60.0 0.0.0.255

access-list 99 permit 192.168.55.0 0.0.0.255

no ip nat inside source list 101 interface GigabitEthernet0/1

ip nat inside source list 99  interface GigabitEthernet0/1


Don't forget to rate helpful posts.

Regards.

Alain

Don't forget to rate helpful posts.
6 REPLIES
Purple

Unable to telnet

Hi,

Do you want to telnet from outside to this server ? then you must have a static PAT for port 23

Have you got ACLs or a firewall config on the router ?

I think it's best you post your config.

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

Re: Unable to telnet

hi,

find the config

sh run

Building configuration...

Current configuration : 3905 bytes

!

! Last configuration change at 12:07:20 UTC Mon Feb 20 2012

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxxx

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$C7ve$1g11FJeUyUmgTBMkg8.3A/

!

no aaa new-model

!

!

!

!

no ipv6 cef

ip source-route

ip cef

!

!

ip dhcp excluded-address 192.168.55.1 192.168.55.10

ip dhcp excluded-address 192.168.60.1 192.168.60.10

!

ip dhcp pool VOICE

network 192.168.55.0 255.255.255.0

default-router 192.168.55.1

option 150 ip 192.168.55.1

dns-server 113.193.1.60 113.193.1.14

!

ip dhcp pool DATA

network 192.168.60.0 255.255.255.0

default-router 192.168.60.1

option 150 ip 192.168.60.1

dns-server 113.193.1.60 113.193.1.14

!

!

ip name-server 113.193.1.60

ip name-server 113.193.1.14

!

multilink bundle-name authenticated

!

!

!

redundancy

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

!

interface GigabitEthernet0/0.55

encapsulation dot1Q 55

ip address 192.168.55.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.60

encapsulation dot1Q 60

ip address 192.168.60.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/1

ip address 113.x.x.157 255.255.255.254

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

!

ip default-gateway 113.x.x.156

ip forward-protocol nd

!

ip http server

ip http secure-server

!

ip nat inside source list 101 interface GigabitEthernet0/1 overload

ip nat inside source static tcp 192.168.60.9 3389 113.x.x.157 3389 extendabl (its server LAN IP-192.168.60.9)

ip route 0.0.0.0 0.0.0.0 113.x.x.156

!

access-list 101 permit ip any any

!

!

!

!

!

tftp-server flash:apps42.9-2-3TH1-9.sbn

tftp-server flash:cnu42.9-2-3TH1-9.sbn

tftp-server flash:cvm42sccp.9-2-3TH1-9.sbn

tftp-server flash:dsp42.9-2-3TH1-9.sbn

tftp-server flash:jar42sccp.9-2-3TH1-9.sbn

tftp-server flash:SCCP42.9-2-3S.loads

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

!

control-plane

!

!

!

line con 0

password 7 04481F0F0126495C0017011E13

login

line aux 0

line vty 0 4

password 7 0215105205010A3345400D1004

login

!

scheduler allocate 20000 1000

end

Regards,

Bhavesh

New Member

Re: Unable to telnet

hi,

i am not able to telnet router from outside.

Regards,

Bhavesh

Purple

Unable to telnet

Hi,

no access-list 101

access-list 99 permit 192.168.60.0 0.0.0.255

access-list 99 permit 192.168.55.0 0.0.0.255

no ip nat inside source list 101 interface GigabitEthernet0/1

ip nat inside source list 99  interface GigabitEthernet0/1


Don't forget to rate helpful posts.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Re: Unable to telnet

hi Alain,

as u replied standard access list to be configured,but will i be able to access sever remotely .

Purple

Unable to telnet

Hi,

you'll be able to start a remote desktop session remotely to the server but not telnet to it.

Is this what you want ?

Can you telnet to the router from outside now ?

Regards.

Alain

Don't forget to rate helpful posts.
347
Views
0
Helpful
6
Replies
CreatePlease to create content