Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unbale to get proper BGP route on remote locations for Fastethernet interface with Primary and Secondary IP address

Hi All,

Below is the configuration done on one of the routers. But remote end sites are not getting 10.101.32.0/22 route at remote lactions via BGP.

IP address @ FastEthernet0/0

  • Prim IP:- 10.101.21.254/23
  • Sec IP :- 10.101.22.254/24


Static Route
ip route 0.0.0.0 0.0.0.0 10.101.20.1

Network advertised in BGP

  • 10.101.20.0/22

interface FastEthernet0/0
ip address 10.101.22.254 255.255.255.0 secondary
ip address 10.101.21.254 255.255.254.0
ip access-group 110 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip pim sparse-mode
ip route-cache flow
no ip mroute-cache
speed 100
full-duplex
end

router1#sho running-config | begin bgp
router bgp xxx
-output omited-
network 10.101.20.0 mask 255.255.252.0
neighbor X.X.X.X remote-as xxx
-output omited-

Tried removing secondary IP from LAN interface and was geting proper route at other end for primary address with same /22 advertisement.

Also added secondary IP address again and advertised specific subnets(network 10.101.20.0 mask 255.255.254.0, network 10.101.22.0 mask 255.255.255.0 ) from BGP at source routes were properly learnt.

router1#sho running-config | begin bgp
router bgp xxx
-output omited-
network 10.101.20.0 mask 255.255.254.0

network 10.101.22.0 mask 255.255.255.0
neighbor X.X.X.X remote-as xxx
-output omited-

Can anybody help me out in finding root cause for this?

5 REPLIES
New Member

Re: Unbale to get proper BGP route on remote locations for Faste

Forgot to mention IOS on router.

sho version
Cisco IOS Software, 1841 Software (C1841-SPSERVICESK9-M), Version 12.4(12a), RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 22-Feb-07 15:56 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Router1 uptime is 1 day, 10 hours, 30 minutes
System returned to ROM by power-on
System restarted at 22:54:27 GMT Mon Jan 11 2010
System image file is "flash:c1841-spservicesk9-mz.124-12a.bin"

Silver

Re: Unbale to get proper BGP route on remote locations for Faste

Hi Manoj,

What do you want to achieve exactly?

You can insert routes into BGP in several ways (network, redistribuiton) but the main thing is that prefix(es) has to be in the routing table already otherwise BGP will not advertise.

Another important thing is the prefix to be advertised has to exactly match the one in the routing table. I'm not talking about here the summary.

The easiest way to do it with network statement and create a static route to null to have the prefix installed in the routing table.

router bgp

network 10.101.20.0 mask 255.255.252.0

ip route 10.101.20.0 255.255.252.0 null0

Hope it helps, rate if does

Krisztian

New Member

Re: Unbale to get proper BGP route on remote locations for Faste

Hi Krisztian,

Thanks for the responce.

The issue here is when i am configuring secondary IP on lan interface, the network is not getting advertised to BGP neighbours.

Can somebody suggest why?

Silver

Re: Unbale to get proper BGP route on remote locations for Faste

Hi,


If I understand correctly once you added the secondary prefix under the network command it was working fine.

It is becasue as I wrote the network command has to exactly match the prefix already in the routing table.

If you want to have both prefixes advertised (i.e not a single one covering both) then you need to have the two network statement. In case you need a single entry covering both let's cover them with 10.101.21.20/22 and create a static route for the same pointing to null.

Hope this helps, rate if does

Krisztian

New Member

Re: Unbale to get proper BGP route on remote locations for Faste

Thanks a lot again...

465
Views
0
Helpful
5
Replies