Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Uni-directional ISDN

Hi all,

If anyone could help troubleshooting my ISDN fault I will gladly give netpro points. I've spent two days and cannot seem to progress.

I have two routers A & B located in two different locations. B's purpose is to dial into A when the primary link goes down. The vendor that manages A swapped their router recently from a no name brand to a Cisco 2811. Site B is a 2600 with BRI card.

When I enable debug ppp & q931 on router B, I can see the call establish and outgoing PPP requests sent. No ACK is seen from router A.

isdn status is "MULTIPLE_FRAME_ESTABLISHED" on both routers

When we debug on the remote router at site A, PPP attempts are being seen both inbound and outbound, showing that these outbound attempts aren't reaching the other end at router B. (debugs attached)

Can anyone see what the problem is. My tests are started with the following command to avoid DDR:

isdn test call int bri 1/0 (isdn number)

Router B config:

interface Dialer1

ip address 10.19.0.2 255.255.255.252

no ip redirects

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer remote-name (remote router name)

dialer idle-timeout 300

dialer string (number)

dialer load-threshold 128 either

dialer watch-group 1

dialer-group 1

no snmp trap link-status

no cdp enable

ppp multilink

int bri 1/0

interface BRI1/0

bandwidth 128

no ip address

no ip redirects

no ip proxy-arp

encapsulation ppp

dialer pool-member 1

no snmp trap link-status

isdn switch-type basic-5ess

fair-queue 64 16 0

no cdp enable

ppp multilink

end

router A config

interface BRI0/3/0

description citigroup

bandwidth 128

no ip address

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool-member 3

dialer idle-timeout 300

isdn switch-type basic-5ess

no fair-queue

no cdp enable

!

interface Dialer3

bandwidth 128

ip address 10.19.0.1 255.255.255.252

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 3

dialer idle-timeout 300

dialer load-threshold 2 either

no fair-queue

no cdp enable

ppp multilink

Thanks! !

8 REPLIES
Community Member

Re: Uni-directional ISDN

Router A debugs:

Log Buffer (4096 bytes):

22305)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: MagicNumber 0x16436A1A (0x050616436A1A)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: MRRU 1524 (0x110405F4)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: EndpointDisc 1 **router B**

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: (0x1312016369746963686D616973646E67)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: (0x7731)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: O CONFACK [ACKsent] id 233 len 37

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: AuthProto CHAP (0x0305C22305)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: MagicNumber 0x16436A1A (0x050616436A1A)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: MRRU 1524 (0x110405F4)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: EndpointDisc 1 **router B**

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: (0x1312016369746963686D616973646E67)

*Aug 22 01:54:59.278: BR0/3/0:1 LCP: (0x7731)

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: Timeout: State ACKsent

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: O CONFREQ [ACKsent] id 139 len 29

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: AuthProto CHAP (0x0305C22305)

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: MagicNumber 0x34F1AFC9 (0x050634F1AFC9)

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: MRRU 1500 (0x110405DC)

*Aug 22 01:54:59.282: BR0/3/0:1 LCP: EndpointDisc 1 **router A** (0x130A0163686D77677731)

*Aug 22 01:55:01.290: BR0/3/0:1 PPP: I pkt type 0xC021, datagramsize 41 link[ppp]

*Aug 22 01:55:01.290: BR0/3/0:1 LCP: I CONFREQ [ACKsent] id 234 len 37

*Aug 22 01:55:01.290: BR0/3/0:1 LCP: AuthProto CHAP (0x0305C22305)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: MagicNumber 0x16436A1A (0x050616436A1A)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: MRRU 1524 (0x110405F4)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: EndpointDisc 1 **router B**

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: (0x1312016369746963686D616973646E67)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: (0x7731)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: O CONFACK [ACKsent] id 234 len 37

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: AuthProto CHAP (0x0305C22305)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: MagicNumber 0x16436A1A (0x050616436A1A)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: MRRU 1524 (0x110405F4)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: EndpointDisc 1 **router B**

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: (0x1312016369746963686D616973646E67)

*Aug 22 01:55:01.294: BR0/3/0:1 LCP: (0x7731)

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: Timeout: State ACKsent

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: O CONFREQ [ACKsent] id 140 len 29

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: AuthProto CHAP (0x0305C22305)

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: MagicNumber 0x34F1AFC9 (0x050634F1AFC9)

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: MRRU 1500 (0x110405DC)

*Aug 22 01:55:01.298: BR0/3/0:1 LCP: EndpointDisc 1 **router A** (0x130A0163686D77677731)

*Aug 22 01:55:03.314: BR0/3/0:1 LCP: Timeout: State ACKsent

*Aug 22 01:55:03.314: BR0/3/0:1 LCP: State is Listen

*Aug 22 01:55:03.314: %ISDN-6-DISCONNECT: Interface BRI0/3/0:1 disconnected from (router B number) **router B**, call lasted 20 seconds

*Aug 22 01:55:03.422: %LINK-3-UPDOWN: Interface BRI0/3/0:1, changed state to down

*Aug 22 01:55:03.422: BR0/3/0:1 PPP: Authorization NOT required

*Aug 22 01:55:03.422: BR0/3/0:1 PPP: No remote authentication for call-in

*Aug 22 01:55:03.422: BR0/3/0:1 PPP: Authorization NOT required

*Aug 22 01:55:03.422: BR0/3/0:1 PPP: No remote authentication for call-in

*Aug 22 01:55:03.422: %DIALER-6-UNBIND: Interface BR0/3/0:1 unbound from profile Di3

*Aug 22 01:55:03.426: BR0/3/0:1 PPP: Sending Acct Event[Down] id[1B]

*Aug 22 01:55:03.426: BR0/3/0:1 LCP: State is Closed

*Aug 22 01:55:03.426: BR0/3/0:1 PPP: Phase is DOWN

*Aug 22 01:55:20.114: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 125 changed to down

*Aug 22 01:55:29.734: %SEC-6-IPACCESSLOGRL: access-list logging rate-limited or missed 2 packets

Community Member

Re: Uni-directional ISDN

Router B debugs:

Community Member

Re: Uni-directional ISDN

Hi,

do you succeed in solving your problem?

I meet the same issue.

I try to configure calling isdn connection with ppp without authentication.

Thanks

Hall of Fame Super Gold

Re: Uni-directional ISDN

Hi,

B never gets any data from A. Which exact IOS is it running ?

Community Member

Re: Uni-directional ISDN

Hi,

thank you for your reply.

I need to check tomorrow the IOS,

In my issue, I manage only Cisco router receiving isdn connection. I need not to use ppp authentication because isdn caller don't use authentication.

I wonder if router A configuration you used is fine.

Here's an output from my config:

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

isdn send-alerting

!

interface Dialer1

ip address 10.0.0.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer idle-timeout 180

dialer caller XXXX

dialer-group 1

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

dialer-list 1 protocol ip permit

Thanks

Hall of Fame Super Gold

Re: Uni-directional ISDN

Looks fine. What matters, is that there is no input packets in the debug for router B.

Community Member

Re: Uni-directional ISDN

Call connect

then on ppp debug I can see:

PPP: authorization required

PPP: no remote authentication for call-in

Then call DISCONECT,

I will try to make a lab to troobleshoot my issue.

The diffirence in my config is that I don't use ppp multilink, do a need a second B channel?

Thanks again

Community Member

Re: Uni-directional ISDN

***dialer idle-timeout 180 ***

can you remove it and see , i think when isdn line is idle it is getting disconnected.Just remove that line and see whether any packet are coming ?

Also i hope you have checked that routes exist properly on both end routers as due to it the isdn may get up and router A may transfer packet to router B but router B might no respond to packet due to routing issues!

********************************

RATE HELPFUL POST

********************************

148
Views
0
Helpful
8
Replies
CreatePlease to create content