Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unicast EIGRP over Frame Relay

Hello,

 

I am having absolutely no luck making unicast EIGRP over frame relay work.

 

(This is for training purposes, and is NOT indicative of any kind of production network. I asked the same question over on learning network and have thus far gotten no answers that fix anything).

 

This is being done on a set of 2901's running IOS 15.3(2)T2. The frame switch is a 3745 running c3745-jk9s-mz.123-9a

 

The scenario is that I have three routers in a hub-and-spoke network

 

I am trying to implement unicast frame relay by setting the neighbors manually, allowing R4 and R2 to form an adjacency, even though they don't have a PVC.

I put static mappings in for everyting just to eliminate any question about mapping.

 

Here are the configurations:

 

FRS:

interface Serial3/2

description <[ S3/2 to R25 s0/0/0 ]>

no ip address

encapsulation frame-relay IETF

clockrate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 41 interface Serial3/3 42

frame-relay route 43 interface Serial3/4 44

!

interface Serial3/3

description <[ S3/3 to R26 s0/0/0 ]>

no ip address

encapsulation frame-relay IETF

clockrate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 42 interface Serial3/2 41

!

interface Serial3/4

description <[ s3/4 to R27 s0/2/0 ]>

no ip address

encapsulation frame-relay IETF

clockrate 128000

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 44 interface Serial3/2 43

!

 

R1:

R1#sh run | se Serial0/0/0

interface Serial0/0/0

ip address 172.16.124.1 255.255.255.248

no ip split-horizon eigrp 1

encapsulation frame-relay IETF

frame-relay map ip 172.16.124.4 43 broadcast

frame-relay map ip 172.16.124.2 41 broadcast

neighbor 172.16.124.2 Serial0/0/0

neighbor 172.16.124.4 Serial0/0/0

R1#sh run | se eigrp

router eigrp 1

network 1.0.0.0

network 10.0.0.0

network 172.16.0.0

neighbor 172.16.124.2 Serial0/0/0

neighbor 172.16.124.4 Serial0/0/0

R1#

 

R2:

R2#sho run | se Serial0/0/0

interface Serial0/0/0

ip address 172.16.124.2 255.255.255.248

encapsulation frame-relay IETF

frame-relay map ip 172.16.124.4 42 broadcast

frame-relay map ip 172.16.124.1 42

neighbor 172.16.124.1 Serial0/0/0

neighbor 172.16.124.4 Serial0/0/0

R2#sho run | sec eigrp

router eigrp 1

network 2.0.0.0

network 10.0.0.0

network 172.16.0.0

neighbor 172.16.124.1 Serial0/0/0

neighbor 172.16.124.4 Serial0/0/0

R2#

 

R4::

R4#sh run | se Serial0/0/0

interface Serial0/0/0

ip address 172.16.124.4 255.255.255.248

encapsulation frame-relay IETF

frame-relay map ip 172.16.124.2 44 broadcast

frame-relay map ip 172.16.124.1 44

neighbor 172.16.124.1 Serial0/0/0

neighbor 172.16.124.2 Serial0/0/0

R4#sho run | se eigrp

router eigrp 1

network 4.0.0.0

network 10.0.0.0

network 172.16.0.0

neighbor 172.16.124.1 Serial0/0/0

neighbor 172.16.124.2 Serial0/0/0

R4#

 

The adjacency between R1 and R4 and R2 and R4 comes up with no problems, but R2 to R4 never comes up.

 

I used debug ip packet with an ACL specifying R2 and R4's s0/0/0 ip address as the source and destination, and I can see that that hellos are sent from R4, I can see that R1 gets them and re-routes them to R2, but R2 NEVER sees them. EIGRP between R1-R4 and R1-R2 is working, and I can ping back and forth between the R2 and R4 interfaces.

 

Here is R4 sending a Hello to R2 (debugging eigrp packets and frame-relay packets)

Apr  2 18:35:42.847: Serial0/0/0(o): dlci 44(0x8C1), NLPID 0x3CC(IP), datagramsize 64

Apr  2 18:35:42.847: EIGRP: Sending HELLO on Se0/0/0 - paklen 20 nbr 172.16.124.2

Apr  2 18:35:42.847:   AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0

 

Here is the routing at R1 (debugging ip packets with an ACL and frame-relay packets)

Apr  2 18:35:42.856: FIBipv4-packet-proc: route packet from Serial0/0/0 src 172.16.124.4 dst 172.16.124.2

Apr  2 18:35:42.856: FIBfwd-proc: packet routed by adj to Serial0/0/0 172.16.124.2

Apr  2 18:35:42.856: FIBipv4-packet-proc: packet routing succeeded

Apr  2 18:35:42.856: Serial0/0/0(o): dlci 43(0x8B1), NLPID 0x3CC(IP), datagramsize 60

Apr  2 18:35:42.856: IP: s=172.16.124.4 (Serial0/0/0), d=172.16.124.2, len 60, input feature, proto=88, packet consumed, MCI Check(94), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

 

And then there is NO OUTPUT at R2 from the IP packet or frame-relay packet debugs (it's seeing the hellos from R1, but not the hellos from R4).

 

Any suggestions would be greatly appreciated.

  • WAN Routing and Switching
Everyone's tags (3)
2 REPLIES
Silver

Hi riedmuellerI tried your

Hi riedmueller

I tried your topology on GNS3, it works fine. I've got neighborship established between R2 and R4 as shown in attached picture. Below the config (see topology.png for interface in use). I just changed interface numbers and add  "frame-relay switching" on FRS to your config. Have a look and let me know.

 

Bye

 

FRS#sh run
Building configuration...

Current configuration : 1590 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
frame-relay switching
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.13.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 description to R1
 no ip address
 encapsulation frame-relay IETF
 clock rate 128000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 41 interface Serial0/1 42
 frame-relay route 43 interface Serial0/2 44
!
interface FastEthernet0/1
 ip address 192.168.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1
 description to R2
 no ip address
 encapsulation frame-relay IETF
 clock rate 128000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 42 interface Serial0/0 41
!
interface Serial0/2
 description to R4
 no ip address
 encapsulation frame-relay IETF
 clock rate 128000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 44 interface Serial0/0 43
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

 

 

R1#              sh run
Building configuration...

Current configuration : 1312 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.124.1 255.255.255.248
 ip hello-interval eigrp 1 5
 ip hold-time eigrp 1 15
 encapsulation frame-relay IETF
 no ip split-horizon eigrp 1
 clock rate 2000000
 frame-relay map ip 172.16.124.4 43 broadcast
 frame-relay map ip 172.16.124.2 41 broadcast
!
interface FastEthernet0/1
 ip address 192.168.13.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 1.0.0.0
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
 neighbor 172.16.124.4 Serial0/0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

 

 

 

 

R2#sh run
Building configuration...

Current configuration : 1252 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.124.2 255.255.255.248
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay map ip 172.16.124.4 42 broadcast
 frame-relay map ip 172.16.124.1 42
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 2.0.0.0
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
 neighbor 172.16.124.1 Serial0/0
 neighbor 172.16.124.4 Serial0/0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

 

 

 

 

 

 

 

 

R4#sh run
Building configuration...

Current configuration : 1224 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.124.4 255.255.255.248
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay map ip 172.16.124.2 44 broadcast
 frame-relay map ip 172.16.124.1 44
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router eigrp 1
 network 4.0.0.0
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
 neighbor 172.16.124.2 Serial0/0
 neighbor 172.16.124.1 Serial0/0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

 

 

 

 

New Member

I am afraid it's a 15.3 thing

I am afraid it's a 15.3 thing, but I can't find any documentation. It seemed to work on 15.2 and I know it work(s)(ed) on 12.4, as you verified in GNS3. I was hoping someone could tell me it was an unresolved bug or 'caveat' in the 15.3(2)T2 release - the release notes don't mention this at all.

 

Thanks for taking a look though

156
Views
0
Helpful
2
Replies