Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Upgrading a 2950 switch

I am new to Cisco. Now I am trying to upgrade my 2950 switch with the latest version IOS. Currently the version my switch has is Version 12.1(22)EA4. I have never done upgrading an IOS before. Please help, someone! Thanks.

4 REPLIES
Hall of Fame Super Blue

Re: Upgrading a 2950 switch

Have a look at this link which gives the details of how to get a new IOS onto your switch

http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_22_ea2/configuration/guide/swiosfs.html#wp1017927

Jon

New Member

Re: Upgrading a 2950 switch

Thanks for your instructions. I followed the instructions, but I kept getting this error: %Error opening tftp://10.10.10.1/c2950-i6q4l2-mz (Socket error)

I had my tftp server started. What can I do at this point. Please help.

New Member

Re: Upgrading a 2950 switch

Hi gia-hoatnguyen,

(please rate)

You can go through the below link to load new IOS into your switch.

http://www.cisco.com/en/US/docs/cable/cmts/ubr7200/configuration/guide/u72_a.html

Note: before copy the new IOS do check the hardware requirement of it carefully. Most of the now IOS are quick big thus they require formatting of the flash. Thus you do not have a fallback if the new IOS do not boot.

New Member

Re: Upgrading a 2950 switch

Thanks for your instructions. I followed the instructions, but I kept getting this error: %Error opening tftp://10.10.10.1/c2950-i6q4l2-mz (Socket error)

I had my tftp server started. What can I do at this point. Please help.

363
Views
10
Helpful
4
Replies