Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Using Private IP to Simulate ISP - unable to ping WAN IP`s

Hi I have a home lab network that is connected to my internet.   I basically have a linksys router connected to cable modem and in order for my families internet to not go down while testing and learning my CCNA I am trying to treat the Linksys as the ISP. 

1. Plugged my 891W router via FASTETHERNET 8 (192.168.1.10)  into LAN Switch port 1 of my Linksys E4200 home router(192.168.1.1).          

2. I plugged my 891W Gigabit 0 (10.10.10.1) LAN side into my 2950 Catalyst Switch (10.10.10.5 - VLAN 1)

3. my 2950 Catalyst switch (10.10.10.5 - Vlan 1) is plugged into my 2600 series router via the routers FE port (10.10.10.2).

There is a few more routers connected behind r2 but I am not dealing with them right now and there is also a switch connected into s1 but its not being used for this.

891w is labled r1

2950 is labled s1

2600 is labeled r2

I am running RIP Verison 2 for my network protocol.

r1 information below

----------------------------

r1#show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 24 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    GigabitEthernet0      2     2
    Vlan4                 2     2
    wlan-ap0              2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.2.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.10.2           120      00:00:02
  Distance: (default is 120)

r1#

----------------------------


r1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.1.1
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Vlan4
L        10.0.0.1/32 is directly connected, Vlan4
C        10.10.10.0/24 is directly connected, GigabitEthernet0
L        10.10.10.1/32 is directly connected, GigabitEthernet0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/24 is directly connected, Vlan1
L        172.16.0.1/32 is directly connected, Vlan1
      172.168.0.0/29 is subnetted, 1 subnets
R        172.168.0.0 [120/2] via 10.10.10.2, 00:00:19, GigabitEthernet0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, FastEthernet8
L        192.168.1.10/32 is directly connected, FastEthernet8
      192.168.2.0/30 is subnetted, 1 subnets
R        192.168.2.0 [120/1] via 10.10.10.2, 00:00:06, GigabitEthernet0
r1#

------------------------------------

r1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r2#

-------------------------------------

===========================================================================================================

===================================================r1 configuration==========================================

show run br
Building configuration...

Current configuration : 3569 bytes
!
! Last configuration change at 16:50:46 UTC Fri Jun 22 2012
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 ENCRYPTED STUFF
!
no aaa new-model
!
!
!
service-module wlan-ap 0 bootimage autonomous
!
crypto pki trustpoint "STUFF REMOVED"
!
ip source-route
!
!
ip dhcp excluded-address 10.0.0.1
ip dhcp excluded-address 172.16.0.1
!
ip dhcp pool Wireless
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   dns-server 192.168.1.2
!
ip dhcp pool WIREDLAN
   network 172.16.0.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 192.168.1.2
!
!
no ip cef
ip domain name MYDOMAINNAME
ip name-server 192.168.1.2
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO891W-AGN-A-K9 sn XXXXXXXXX
!
!
archive
log config
  hidekeys
username USERNAME privilege 15 secret 5 ENCRYPTEDSTUFF
!
!
!
!
!
bridge irb
!
!
!
!
interface FastEthernet0
spanning-tree portfast
!
!
interface FastEthernet1
spanning-tree portfast
!
!
interface FastEthernet2
spanning-tree portfast
!
!
interface FastEthernet3
spanning-tree portfast
!
!
interface FastEthernet4
shutdown
spanning-tree portfast
!
!
interface FastEthernet5
spanning-tree portfast
!
!
interface FastEthernet6
spanning-tree portfast
!
!
interface FastEthernet7
shutdown
spanning-tree portfast
!
!
interface FastEthernet8
description $ES_WAN$$FW_OUTSIDE$
ip address 192.168.1.10 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
!
interface GigabitEthernet0
description $ES_WAN$$FW_OUTSIDE$
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan4
arp timeout 0
!
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
switchport trunk native vlan 4
switchport mode trunk
!
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$CVO$$FW_INSIDE$
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
!
interface Vlan4
description $FW_INSIDE$
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
interface Async1
no ip address
encapsulation slip
!
!
router rip
version 2
network 10.0.0.0
network 192.168.2.0
!
no ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface FastEthernet8 overload
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
access-list 1 permit any
!
!
!
!
!
!
control-plane
!
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
logging synchronous
login local
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin udptn ssh
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end

r1#

=======================================================================================================

=======================================================================================================

r2 information:

r2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 23 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    Serial0/0             2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.1.0
    192.168.2.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.10.1           120      00:00:05
    192.168.1.35         120      3d15h
    192.168.1.1          120      4d13h
    192.168.2.2          120      00:00:16
  Distance: (default is 120)

-----------------------------------------

r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.168.0.0/29 is subnetted, 1 subnets
R       172.168.0.0 [120/1] via 192.168.2.2, 00:00:25, Serial0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
R       10.0.0.0 [120/1] via 10.10.10.1, 00:00:14, FastEthernet0/0
     192.168.2.0/30 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, Serial0/0

---------------------------------

r2#ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
r2#

------------------------------------

2#ping 192.169.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.169.1.10, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r2#

-------------------------------------

I can ping all over my homelab everything I can reach as long as I have a protocol up but I cannot reach the WAN IPs.  I watched video by Jeremy Ciorara and I tried to follow the wan and nat part from a website http://www.networkstraining.com/basic-cisco-800-router-configuration-for-internet-access/

And none of its working.  I am not sure if this is a case where a private IP cannot function as a ISP and I am breaking some rule thats not mentioned in CCNA studies or if its something else.

I tried these commands from Jeremy Video:

r1(config)#ip access-list standard "NAT_ADDRESSES"

r1(config-std-nacl)#permit any

r1(config)ip nat inside source list NAT_ADDRESSES interface fastEthernet 8 overload

However they did not work it was pretty close to whats in the basic website up there I listed as well.

I think I went back to the basic configuration in the config file post above.  Its really frustrating as I follow directions and they do not seem to work. I understand I am using my private 192.168.1.0 subnet as an ISP and maybe that has something to do with it but when yoru first learning and things dont work its kind of overwelming as you have problems seeing the big picture and dont yet trust in things you have learned as they are unfamiliar so its easy to get lost.

Anyway any asistance would be great. I will also keep trying to figure this out but so far I have only came up with non working ideas.

Thanks,

Brian

Everyone's tags (8)
1 REPLY
Bronze

Using Private IP to Simulate ISP - unable to ping WAN IP`s

you are not getting any default route on R2.

regards

shivlu Jain    

1284
Views
0
Helpful
1
Replies
CreatePlease login to create content