Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Very Odd OSPF Problem

Hi all,

I have a very odd OSPF issue.

I have a 6509 router with a DS3 card doing frame-relay to multiple end sites. These end sites all have 2800 routers.

All of my end sites talk OSPF just fine except for one.

On the low end 2800 router, this is what I have:

6d08h: OSPF: Send hello to 224.0.0.5 area 10.125.0.0 on Serial0/2/0.30 from 10.1

25.2.102

6d08h: OSPF: Send hello to 224.0.0.5 area 10.125.0.0 on FastEthernet0/0 from 10.

126.30.254

6d08h: OSPF: rcv. v:2 t:1 l:44 rid:10.120.16.1

aid:10.125.0.0 chk:C8AF aut:1 auk: from Serial0/2/0.30

6d08h: OSPF: Rcv hello from 10.120.16.1 area 10.125.0.0 from Serial0/2/0.30 10.1

25.2.97

6d08h: OSPF: Send immediate hello to nbr 10.120.16.1, src address 10.125.2.97, o

n Serial0/2/0.30

6d08h: OSPF: Send hello to 224.0.0.5 area 10.125.0.0 on Serial0/2/0.30 from 10.1

25.2.102

6d08h: OSPF: End of hello processing

So you can see that the 2800 is both receiving and sending hellos. On the 6509 side, it is only SENDING hellos, not receiving any from the 2800.

This is a normal configuration, I have no ACL's, no sorts of filters or anything. I can get IP routing working fine when I use static routes, but not OSPF.

We have talked to the phone company on numerous occasions and they say they have completely rebuilt this frame connection, but still nothing is getting through.

Its almost as though on the 6509 side, it cannot talk multicast to this router. When I do a multicast ping, this particular router does not respond while all others do.

2800 Router Config:

interface Serial0/2/0

no ip address

encapsulation frame-relay

load-interval 30

fair-queue

frame-relay lmi-type ansi

!

interface Serial0/2/0.30 point-to-point

bandwidth 1544

ip address 10.125.2.102 255.255.255.248

ip accounting output-packets

ip ospf authentication-key 7 ***

frame-relay interface-dlci 30

router ospf 1

log-adjacency-changes

area 10.125.0.0 authentication

area 10.125.0.0 stub

network 10.125.0.0 0.0.255.255 area 10.125.0.0

network 10.126.0.0 0.0.255.255 area 10.125.0.0

As you can see, without the other hello, it can only stay in INIT state:

Neighbor ID Pri State Dead Time Address Interface

10.120.16.1 0 INIT/ - 00:00:38 10.125.2.97 Serial0/2/0.30

6509 side:

interface Serial1/0/0.313 point-to-point

bandwidth 1544

ip address 10.125.2.97 255.255.255.248

ip flow ingress

ip ospf authentication-key 7 ***

frame-relay interface-dlci 313

router ospf 1

log-adjacency-changes detail

area 0.0.0.0 authentication

area 10.125.0.0 authentication

area 10.125.0.0 stub no-summary

area 10.125.0.0 range 10.125.0.0 255.255.0.0

area 10.125.0.0 range 10.126.0.0 255.255.0.0

network 10.120.0.0 0.0.255.255 area 0.0.0.0

network 10.125.0.0 0.0.255.255 area 10.125.0.0

Interface Serial1/0/0.313

OSPF packets received/sent

Invalid Hellos DB-des LS-req LS-upd LS-ack Total

Rx: 0 1410197 781 148 7497 208556 1627179

Tx: 0 2079999 961 202 222446 7305 2310913

OSPF header errors

Length 0, Checksum 0, Version 0, Bad Source 0,

No Virtual Link 0, Area Mismatch 0, No Sham Link 0,

Self Originated 0, Duplicate ID 0, Hello 0,

MTU Mismatch 0, Nbr Ignored 0, LLS 0,

Unknown neighbor 0, Authentication 0,

OSPF LSA errors

Type 0, Length 0, Data 0, Checksum 0,

The Rx Hellos DO NOT INCREASE. They are staying the same.

This router worked at one point at which there was some sort of issue. Maybe power. We have replaced the router at this location 3 seperate times with all new hardware.

The phone company swears they arent blocking multicast...

Any ideas?

Thanks!

2 REPLIES

Re: Very Odd OSPF Problem

HI,

The cause for the Multicast IP not reachable beacause the provider might be blocking the same.

Try establishing OSPF on NBMA and test the Services. The sample configuration is as below:

PE Side Configuration

----------------------

interface

description ***Customer Name***

encapsulation dot1Q xyz

ip vrf forwarding

ip address aaa.bbb.ccc.ddd 255.255.255.252

ip mtu 1500

ip ospf network non-broadcast

no cdp enable

end

!

router ospf vrf

log-adjacency-changes

network aaa.bbb.ccc.ddd 0.0.0.3 area 0

neighbor aaa.bbb.ccc.eee

!

CE Side Configuration

----------------------

interface

description ***Customer Name***

encapsulation dot1Q xyz

ip address aaa.bbb.ccc.eee 255.255.255.252

ip ospf network non-broadcast

no cdp enable

end

!

router ospf

log-adjacency-changes

network aaa.bbb.ccc.ddd 0.0.0.3 area 0

neighbor aaa.bbb.ccc.ddd

!

Hope I am Informative. Pls RATE if HELPS

Best Regards,

Guru Prasad R

New Member

Re: Very Odd OSPF Problem

Thanks for the response. I have verified that the provider is not blocking multicast traffic.

I have FIXED this issue. I will leave this question out here for a bit longer though to see if someone would like to try and answer the question before I post the solution.

405
Views
0
Helpful
2
Replies
CreatePlease login to create content