cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5230
Views
10
Helpful
4
Replies

Very simple 1841 PPPoE config

Kim Holburn
Level 1
Level 1

I'm trying to get a PPPoE config working on an 1841.  Running c1841-advsecurityk9-mz.124-3i.bin . I tried c1841-advsecurityk9-mz.151-4.M4.bin but it has even less protocol options.

I used a walkthrough but it suggests the following fragment which doesn't work because there is no "protocol ppoe" command available on my system.  Perhaps there is a simpler way to do this?  I tried c1841-broadband-mz.151-4.M4.bin but it doesn't seem to have ssh available.

vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
exit

My config looks something like this:

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
service sequence-numbers
!
hostname myhostname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xxxxxxxx
!
aaa new-model
!
!
aaa authentication login local_auth local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
ip domain name mydomainname.com
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
vpdn enable
!
!
interface FastEthernet0/0
description ADSL WAN connection
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
duplex auto
speed auto
pppoe enable
no cdp enable
!
interface FastEthernet0/1
ip address 10.1.1.5 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
!
interface Vlan1
no ip address
!
interface Dialer1
description ADSL WAN Dialer
ip address negotiated
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname myname@myisp
ppp chap password d xxxxxxxx
ppp pap sent-username myname@myisp password d xxxxxxxx
ppp ipcp route default
!
ip classless
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 10 interface Dialer1 overload
ip nat inside source static 10.1.1.6 15.14.13.12
!
logging trap debugging
logging facility local6
access-list 10 permit 10.1.0.0 0.0.255.255
access-list 23 permit 10.1.0.0 0.0.255.255
dialer-list 1 protocol ip permit
no cdp run
!

1 Accepted Solution

Accepted Solutions

Peter Paluch
Cisco Employee
Cisco Employee

Hello Kim,

The VPDN configuration is not relevant to what you are trying to accomplish. Please remove all VPDN-related commands, i.e.:

no vpdn-group 1

no vpdn enable

What you are currently missing in the configuration you posted is a simple line on the FastEthernet0/0 interface:

pppoe-client dial-pool-number 1

Adding this line should successfully start the PPPoE client and tie its operation to the Dialer1 interface.

Also, please remove the  ppp authentication chap pap callin line from your Di1 interface - it is again not relevant to your configuration. The authentification will still work successfully but this command is used to perform an authentication in the reversed direction during callbacks - clearly not your case here.

Best regards,

Peter

View solution in original post

4 Replies 4

Peter Paluch
Cisco Employee
Cisco Employee

Hello Kim,

The VPDN configuration is not relevant to what you are trying to accomplish. Please remove all VPDN-related commands, i.e.:

no vpdn-group 1

no vpdn enable

What you are currently missing in the configuration you posted is a simple line on the FastEthernet0/0 interface:

pppoe-client dial-pool-number 1

Adding this line should successfully start the PPPoE client and tie its operation to the Dialer1 interface.

Also, please remove the  ppp authentication chap pap callin line from your Di1 interface - it is again not relevant to your configuration. The authentification will still work successfully but this command is used to perform an authentication in the reversed direction during callbacks - clearly not your case here.

Best regards,

Peter

Many thanks, I'll give that a try.

Thanks, worked perfectly.

ThankU
Review Cisco Networking products for a $25 gift card