Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

virtaul interfaces on 2821

can someone please help me to validate the following interface config:

!

interface GigabitEthernet0/0

description $CONNECTION TO LAN$

no ip address

duplex auto

speed 100

!

interface GigabitEthernet0/0.1

description $NATIVE_Data$

encapsulation dot1Q 1

ip address 172.20.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.20

description $CONFIG_CNTR$

encapsulation dot1Q

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.200.254 {another DHCP server on HP switch trunked to cat3560 switch which is connected to the Cisco on GI0/0 as the voice switch}

ip nat inside

ip virtual-reassembly

!

interface GigabitEthernet0/0.50

description $VOICE$

encapsulation dot1Q

ip nat inside

ip virtual-reassembly

Q: do i need to give ip add to vlan 50 or i can just leave it part of the native vlan.

thank you in advance

3 REPLIES
Hall of Fame Super Gold

Re: virtaul interfaces on 2821

You need a VLAN ID for each encapsulation dot1q, and an IP address for each subinterface.

You do not need "ip virtual-reassembly".

New Member

Re: virtaul interfaces on 2821

can i do:

vlan 1 for example: 172.20.2.0

vlan 20 192.168.2.0

vlan 50 172.20.1.0

under int .20 i have an ip add helper to point to another dhcp server, is that the way to do it?

thank you so much for your help.

Hall of Fame Super Gold

Re: virtaul interfaces on 2821

Yes.

Please remember to rate useful posts with the scrollbox below.

113
Views
0
Helpful
3
Replies
CreatePlease to create content