Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN and DHCP

1760 Router - 2960 Catalyst

I'm running multiple VLAN's - I'm able to pull DHCP on native vlan - but nothing else.

Router

ip dhcp pool 1

network 192.168.74.0 255.255.255.0

dns-server 10.132.80.5 10.132.80.6

netbios-name-server 10.132.80.5 10.132.80.6

default-router 192.168.74.1

lease 3

!

ip dhcp pool 2

network 10.132.74.0 255.255.255.0

default-router 10.135.74.1

dns-server 10.132.80.5 10.132.80.4

netbios-name-server 10.132.80.5

lease 3

!

ip dhcp pool 3

network 10.135.74.0 255.255.255.0

default-router 10.135.74.1

netbios-name-server 10.132.80.5

lease 3

!

interface FastEthernet0/0

no ip address

speed auto

full-duplex

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.74.1 255.255.255.0

!

interface FastEthernet0/0.2

description XXX LAN

encapsulation dot1Q 2

ip address 10.132.74.1 255.255.255.0

!

interface FastEthernet0/0.3

description XXX VOIP LAN

encapsulation dot1Q 74

ip address 10.135.74.1 255.255.255.0

Switch

interface FastEthernet0/23

switchport access vlan 2

switchport mode access

spanning-tree portfast

vlan 2

name LAN

3 REPLIES
Community Member

Re: VLAN and DHCP

You might need to configure a dhcp relay agent.

Community Member

Re: VLAN and DHCP

Thanks, native vlan attached to fa0/0.1 is working and not using a helper.

HOSTNAME#show ip interface fastethernet0/0.1

FastEthernet0/0.1 is up, line protocol is up

Internet address is 192.168.74.1/24

Broadcast address is 255.255.255.255

Address determined by non-volatile memory

MTU is 1500 bytes

Community Member

Re: VLAN and DHCP

Hi,

Since we are using the on board DHCP server, we don't need no relay agent.

Are we getting the discover or the request packets on to the switch? Enable debug using the following:

debug ip dhcp server {events | packets | linkage}

If the Bootp packets are not coming along onto the switch, then we have some connection issues, if they do but the switch does not reply back, then we have some issues with the switch.

-/ Kiran

275
Views
0
Helpful
3
Replies
CreatePlease to create content