Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN DHCP to WAN http/https access

New to IOS, working with an 819 ISR. I am trying to configure the VLAN DHCP for LAN switch port to access the WAN interface for HTTP/HTTPS. I assume this would be some kind of ACL or Access Group. 

 

Current configuration : 2795 bytes
!
! Last configuration change at 20:32:47 UTC Fri Jul 18 2014 by test
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname bob
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
logging buffered 51200 warnings
no logging console
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-476046398
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-476046398
 revocation-check none
 rsakeypair TP-self-signed-476046398
!
!
crypto pki certificate chain TP-self-signed-476046398
!
!
!
!


!
ip dhcp excluded-address 192.168.34.1
ip dhcp excluded-address 192.168.34.2 192.168.34.99
ip dhcp excluded-address 192.168.34.150 192.168.34.254
!
ip dhcp pool sdm-pool
 import all
 network 192.168.34.0 255.255.255.0
 default-router 192.168.34.1
 dns-server 8.8.8.8 4.2.2.2
 lease 0 2
!
!
!
ip domain name yourdomain.com
ip name-server 8.8.8.8
ip name-server 4.2.2.2
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
!
!
!
!
license udi pid C819G-4G-V-K9 sn FTX182083AB
!
!
username cisco privilege 15 secret 5 $1$7bp8$MgueJzd0Gxu.fyyzGfJnS/
username test privilege 15 secret 5 $1$UbUY$1pNrtyLEV6g64a97hPWGC1
!
!
!
!
!
controller Cellular 0
!
!
!
!
!
!
!
!
!
!
!
interface Cellular0
 no ip address
 encapsulation slip
 dialer in-band
 dialer string lte
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface GigabitEthernet0
 ip address 192.168.0.122 255.255.255.0
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Serial0
 no ip address
 shutdown
 clock rate 2000000
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
 ip address 192.168.34.1 255.255.255.0
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 199 interface GigabitEthernet0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0
!
!
access-list 100 permit ip 0.0.0.0 255.255.255.0 any
access-list 101 permit ip any 0.0.0.0 255.255.255.0
access-list 102 permit icmp any any
access-list 199 permit ip any any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line 3
 script dialer lte
 no exec
line vty 0 4
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

1 REPLY
New Member

Got it for now, Added VLAN 1

Got it for now,

 

Added 

VLAN 1 

ip nat inside

 

Interface GigabitEthernet 0

ip nat outside

26
Views
0
Helpful
1
Replies