Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN question

We have two Cat6509 switches as the core in a network distributing L2 VLANs accross Trunk uplinks to non-Cisco edge switches. The trunks have 802.1q and pass extended VLANs. We are seeing a problem with two new VLANs that we created, they appear to be fowarding in STP, but the IP we are running over the VLAN doesn't appear to connect over one particular uplink. This uplink was already in use prior to adding the new VLANs (1050 & 1060) and has been passing VLAN traffic just fine. I added 11050 and 1060 to other trunk uplinks, and we are able to pass the IP without any problem. the interface examples are below:

VLAN 1050 & 1060 do not pass IP

interface GigabitEthernet1/9

description Uplink to len-s2262-1

no ip address

load-interval 30

speed nonegotiate

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 2997

switchport trunk allowed vlan 1040,1043,1047,1050,1060,1120-1122,1185

switchport trunk allowed vlan add 2009-2011,2018-2020,2047,2050,2060,2115,2250

switchport mode trunk

switchport nonegotiate

switchport vlan mapping enable

no cdp enable

**************************

VLAN 1050 & 1060 pass IP just fine.

interface GigabitEthernet2/4

description trunk to B109-1 port 3/18 (LEN Stack)

no ip address

load-interval 30

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 2997

switchport trunk allowed vlan 1040,1043,1047,1050,1060,1120-1122,1137

switchport trunk allowed vlan add 1185-1188,1200,2008-2012,2018-2020,2027,2029

switchport trunk allowed vlan add 2030,2047,2050,2060,2108,2115,2200,2201,2250

switchport trunk allowed vlan add 2256-2260

switchport mode trunk

switchport nonegotiate

switchport vlan mapping enable

no cdp enable

end

interface GigabitEthernet1/12

description Uplink to B120

no ip address

load-interval 30

speed nonegotiate

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 2997

switchport trunk allowed vlan 1050,1060,1185,1186,1200,2010,2011,2020,2250

switchport mode trunk

switchport nonegotiate

switchport vlan mapping enable

no cdp enable

end

interface GigabitEthernet1/24

description Link to KHHUB

no ip address

load-interval 30

speed nonegotiate

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 2997

switchport trunk allowed vlan 1040,1050,1060,1120-1122,1185,2010,2019,2250

switchport mode trunk

switchport nonegotiate

switchport vlan mapping enable

no cdp enable

end

I have already rebooted the edge switch and verified it is running the same code as the other edge switches. It is a Baystack 470.

Any thoughts or suggestions?

5 REPLIES

Re: VLAN question

Have you checked the config on the Baystack?

It could be that the vlanID is not existing on it or not bound to the corresponding interface.

regards,

Leo

New Member

Re: VLAN question

I verified that the VLAN ID is on the edge switch and is being tagged on the trunk port.

Tnx, Dave.

Re: VLAN question

It strikes me that 1040 and 1050 are quite low numbers, and quite close to the magic 1025 where the internal VLANs start. Do you have any layer-3 routed interfaces that might be using these VLAN allocations already? Do a show vlan internal usage to find out.

Kevin Dorrell

Luxembourg

New Member

Re: VLAN question

This is the output for that command:

VLAN Usage

---- --------------------

1006 online diag vlan0

1007 online diag vlan1

1008 online diag vlan2

1009 online diag vlan3

1010 online diag vlan4

1011 online diag vlan5

1012 PM vlan process (trunk tagging)

1013 L3 multicast partial shortcuts for VPN 0

1014 Egress internal vlan

1015 Egress internal vlan

1016 GigabitEthernet1/1

1017 GigabitEthernet1/3

1018 vr0

1019 GigabitEthernet2/43

1020 GigabitEthernet2/5

1021 GigabitEthernet1/5

1022 GigabitEthernet2/7

No other L3 interfaces using those tags. I did create two additional VLANs, 2050 & 2060, and got the same result. I just couldn't pass the IP accross those VLANs on that uplink.

New Member

Re: VLAN question

Well, this was an issue of incorrect documentation here. The active uplink was on the 2nd core Cat6509 instead of the 1st. I added the VLANs to the appropriate uplink, and it works.

Thank you for your replies and help.

Dave.

218
Views
0
Helpful
5
Replies