Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlan's on router

Hi Seniors,

I understand that vlan's can be created on cisco switches but last day I was looking on the configuration of my office cisco router and I saw configuration on vlans interfaces. I ran the command "sh int vlan20" and I saw the interface. My questions 

1-what are these vlan interfaces on router ?( if they are virtual , what is physical interface looks like for actual connection to router)

2-Is vlan interfaces different than virtual interfaces and how ?

3-How to configure vlan interfacs on router and for what purpose ?

4-What cisco router models that we can define vlans on ?

Thanks for reply. If someone knows a website the above explanation, I would appriciate.

Tahir.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: vlan's on router

Hello Tahir,

modern IOS routers like 1800, 2800, 3800 series but also 3700 series and late 2600 can host small LAN switches modules.

My guess is that your router has one of them.

There two types of these modules:

those that are configured from the router itself

those that are a separate logical device with its own configuration.


in your case should be a module of first type.

So the questions can now be answered:

1) They are logical L3 interfaces so called SVI = switched virtual interfaces they provide layer 3 services (a gateway) to corresponding L2 Vlan.

the L2 vlan can be associated to one or multiple switch ports of the module and they are configured like in an IOS LAN switch.

2) Vlan interfaces are a form of logical interfaces like loopbacks but: an SVI vlan 10 can be up/up only if at least one switch port is up and associated to vlan 10 (including trunk ports and actually the correct definition is at least one port in Spanning tree state forwarding). Note: this is true for real switches it can be false for these modules on routers (the internal trunk between router and module can be enough to make the L3 SVI to stay up)

3)

First of all the corresponding L2 object Vlan has to be created, it is likely that you should use vlan database context

example:

router# vlan database

router(vlan)# vlan 10

router(vlan)# name test10

router(vlan)#apply

router(vlan)#exit

apply or exit are needed to have the new vlan created

then interface vlan 10 can be configured

config t

interface vlan 10

ip address 10.10.10.1 255.255.255.0

! you need to enable with no shut

no shut

ports in module can be associated to L2 broadcast domain vlan 10

int fas1/1

switchport

switchport mode access

switchport access vlan 10

the port can be used as a LAN switch port

4) as stated above multiservice routers (C3700, C2600) and ISR routers (1800,2800,3800) and new ISR G2 (1900,2900,3900) can host these modules

see

http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Hope to help

Giuseppe

3 REPLIES
Hall of Fame Super Silver

Re: vlan's on router

Hello Tahir,

modern IOS routers like 1800, 2800, 3800 series but also 3700 series and late 2600 can host small LAN switches modules.

My guess is that your router has one of them.

There two types of these modules:

those that are configured from the router itself

those that are a separate logical device with its own configuration.


in your case should be a module of first type.

So the questions can now be answered:

1) They are logical L3 interfaces so called SVI = switched virtual interfaces they provide layer 3 services (a gateway) to corresponding L2 Vlan.

the L2 vlan can be associated to one or multiple switch ports of the module and they are configured like in an IOS LAN switch.

2) Vlan interfaces are a form of logical interfaces like loopbacks but: an SVI vlan 10 can be up/up only if at least one switch port is up and associated to vlan 10 (including trunk ports and actually the correct definition is at least one port in Spanning tree state forwarding). Note: this is true for real switches it can be false for these modules on routers (the internal trunk between router and module can be enough to make the L3 SVI to stay up)

3)

First of all the corresponding L2 object Vlan has to be created, it is likely that you should use vlan database context

example:

router# vlan database

router(vlan)# vlan 10

router(vlan)# name test10

router(vlan)#apply

router(vlan)#exit

apply or exit are needed to have the new vlan created

then interface vlan 10 can be configured

config t

interface vlan 10

ip address 10.10.10.1 255.255.255.0

! you need to enable with no shut

no shut

ports in module can be associated to L2 broadcast domain vlan 10

int fas1/1

switchport

switchport mode access

switchport access vlan 10

the port can be used as a LAN switch port

4) as stated above multiservice routers (C3700, C2600) and ISR routers (1800,2800,3800) and new ISR G2 (1900,2900,3900) can host these modules

see

http://www.cisco.com/en/US/docs/ios/lanswitch/configuration/guide/lsw_hwic_ethsw_ic_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Hope to help

Giuseppe

New Member

Re: vlan's on router

Thanks Giuseppe

Explaination is really helpful.

Tahir.

New Member

vlan's on router

Question SVI on a Router

I have the same situation going on, but my SVI interface is up down status

I have an HSRP environment and the primary router is providing the connectivity
when I look at the vlan database on the primary router the SVI interface is UP UP

The deference is that the vlan database contain the vlan in the vlan database.

Question

the secondary router SVI interface show UP DOWN is that because it does not have
the vlan interface in the vlan database. If so, once I add the vlan to the database; will the

SVI state chance to up up or is there any additional steps required to bring the interface

To an status of  UP UP

Thanks

8728
Views
0
Helpful
3
Replies