Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

vlans cannot ping router

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml

we setup our switch according to the document linked above.  The nodes in the vlans can ping each other.  The switch can ping the router.  However, the nodes cannot ping the router.  I reviewed the TBS steps listed, but the issue still remains.  I think my addressing is correct because i can ping the router by logging on via terminal session and sending a ping with defaults.  However, if I set ping to use a vlan ip, it is unsuccessful.

Is there anything else I can try?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

vlans cannot ping router

Curtis

So clients in one vlan can ping clients in another vlan ?

If so couple of things to check (assuming you are using static routing and not a dynamic routing protocol) -

1) on the L3 switch you need a default-route pointing to the router LAN interface ie.

ip route 0.0.0.0 0.0.0.0

2) on the router you need to add routes for each of your vlans on the L3 switch ie.

ip route 192.168.5.0 255.255.255.0 

you need an ip route statement on the router for each of the L3 vlans on the switch.

Jon

2 REPLIES
Hall of Fame Super Blue

vlans cannot ping router

Curtis

So clients in one vlan can ping clients in another vlan ?

If so couple of things to check (assuming you are using static routing and not a dynamic routing protocol) -

1) on the L3 switch you need a default-route pointing to the router LAN interface ie.

ip route 0.0.0.0 0.0.0.0

2) on the router you need to add routes for each of your vlans on the L3 switch ie.

ip route 192.168.5.0 255.255.255.0 

you need an ip route statement on the router for each of the L3 vlans on the switch.

Jon

New Member

vlans cannot ping router

Thanks, Jon.  You were right.  I was not using any dynamic routing protocol.  I was able to ping the router after adding the route int he router.  The default route was already setup.

2385
Views
0
Helpful
2
Replies
CreatePlease to create content