Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Voice quality issues

Hi, Cisco gurus I'm wondering if someone can help me solve a problem I'm having. This problem has been going on for over 1 year I have talked with Cisco, ISP, Mitel and the problem is still not resolved. Our network is not a complex one. We have a host site which is connected to 6 remote sites via MPLS, Norlight is the ISP. At each site is a Mitel 3300 VoIP system.

At the host site we have an IMA group (ATM) 3mbs connection and at the remote sites we have 1.5mbs Frame connections.

The symptoms of the problems are this. High jitter and garbled sounding voices on both ends. The problem seems more sever on the host site end near the IMA group. The calls break up like you hear every other word. I checked the bandwidth usage on the host router and it is not even 1mps most of the time. The remote routers show 200 or 300 kps most of the time.

There are some traffic shaping drops outbound from the host site but they are less then 1%.

The policy map is not showing any drops.

I have asked the ISP about implementing FRF.12 they do not support it.

Let me know if you need me to post any more information.

Host site config

class-map match-all Wan-RTP

match access-group name Voice-ACL

class-map match-any Lan-Ingress-RTP-COS-6-DSCP-44

match dscp 44

match cos 6

class-map match-any Lan-Ingress-RTP

match dscp ef

class-map match-all Lan-Policy-Egress-Set-COS-6

match access-group name Voice-ACL-BranchPlants

!

!

policy-map Wan-Policy-Voice-PVC

class Wan-RTP

priority percent 75

set dscp ef

class class-default

fair-queue

random-detect

policy-map Lan-Policy-Egress

class Lan-Policy-Egress-Set-COS-6

set cos 6

interface ATM0/IMA0

no ip address

load-interval 30

no atm ilmi-keepalive

!

interface ATM0/IMA0.100 point-to-point

description PVC to Norlight MPLS Network VPI/VCI 5/100 - Voice

ip address 192.168.1.2 255.255.255.252

ip flow ingress

pvc 5/100

vbr-nrt 3072 3072

tx-ring-limit 7

oam-pvc manage

encapsulation aal5snap

service-policy output Wan-Policy-Voice-PVC

!

Remote site configs:

policy-map Wan-Policy-Voice

class Wan-RTP

priority percent 75

set dscp ef

class class-default

fair-queue

random-detect

set dscp default

policy-map Lan-Policy-Ingress

class Lan-Ingress-RTP

set dscp ef

class class-default

set dscp default

!

interface Serial0/0

description 768K to Waverly, OH

bandwidth 1536

no ip address

encapsulation frame-relay IETF

ip route-cache flow

no fair-queue

service-module t1 timeslots 1-24

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0.100 point-to-point

description PVC to Norlight's MPLS Network DLCI 100 - Voice

bandwidth 1536

ip address 192.168.1.14 255.255.255.252

frame-relay interface-dlci 100 IETF

class VoIP-QoS

map-class frame-relay VoIP-QoS

frame-relay cir 1536000

frame-relay bc 15360

frame-relay be 0

frame-relay mincir 1536000

service-policy output Wan-Policy-Voice

2 REPLIES
Hall of Fame Super Gold

Re: Voice quality issues

Hi,

The problem may be very well with you SP MPLS cloud.

vbr-nrt 3072 3072

seems a little too much, Note the second parameter is the burst size expressed in cells and not the repetition of the first. But it would matters, as w/ an access speed of 3072 theres is nothign to burst.

Same at the remote, you cir configuration have no effect as all they do is setting CIR same as access speed.

I haven't looked at the rest, before anything else please investigate the service parameters, ask if they are honoring dscp ef.

If the SP doesn't respond satisfactorily, try reducing the speed of ATM and FR shaping even drastically and obsverse results.

Silver

Re: Voice quality issues

Tx-ring is also quite large for my taste.

Also, "class-map match-all Wan-RTP" should also match dscp EF.

For starters:

Configure IP SLA and look at the statistics, so you have arguments more quantifiable than "garbled sounding voices on both ends".

http://www.cisco.com/en/US/partner/products/ps6441/products_configuration_guide_chapter09186a0080707255.html

Hope this helps

191
Views
0
Helpful
2
Replies
CreatePlease to create content