Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

VPLS ASR 1004 device

How to configure VPLS on ASR 1004 device.Which version ASR support this functionality.

Please provide configuration doc (VPLS ASR)

4 REPLIES
Cisco Employee

Re: VPLS ASR 1004 device

Hi,

VPLS is not supported currently on the ASR1000 but should be in the future.

HTH

Laurent.

New Member

   Excuse me ! ASR 1004 can

   Excuse me ! ASR 1004 can support VPLS now ? 

Looking forward to your reply ,thanks!

Cisco Employee

Hi, Yes. It is supported now.

Hi,

 

Yes. It is supported now.

 

-Nagendra

New Member

Dear Nagendra,    Thanks your

Dear Nagendra,

    Thanks your reply !    I used  this devices to configure VPLS  ( 3750--7609 -----ASR 1004 --2950  ), but the VC status is down .I referenced the  official configuration  and asked my friends ,still couldn't find the reasons. It's the  issue of devices  compatibility ?

    If you have time ,can you help me Analysis the problem ?

    

Thank you very much !

 

********************************************

7609:
mpls label protocol ldp
mpls ldp neighbor 10.10.10.102 targeted ldp
mpls ldp discovery hello holdtime 5
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force


l2 router-id 10.10.10.101
l2 vfi aaa manual 
 vpn id 101
 neighbor 10.10.10.102 encapsulation mpls

 

interface Loopback0
 ip address 10.10.10.101 255.255.255.255

interface GigabitEthernet5/2  (to 3750)
 switchport
 switchport access vlan 101
 switchport mode access
 media-type rj45
 speed 100
!

interface GigabitEthernet6/2   (to ASR1004 )
 ip address 12.1.1.1 255.255.255.252
 media-type rj45
 mpls ip
 mpls label protocol ldp
!

interface Vlan101
 no ip address
 xconnect vfi aaa
!

router eigrp 90
 network 10.10.10.101 0.0.0.0
 network 12.1.1.0 0.0.0.3
!


************************************

ASR1004:

mpls label protocol ldp
mpls ldp neighbor 10.10.10.101 targeted ldp
mpls ldp discovery hello holdtime 5
mpls ldp discovery targeted-hello accept
mpls ldp router-id Loopback0 force

bridge-domain 101 

l2 router-id 10.10.10.102     
l2 vfi aaa manual      
 vpn id 101
 bridge-domain 101
 neighbor 10.10.10.101 encapsulation mpls

 

interface Loopback0
 description test vpls
 ip address 10.10.10.102 255.255.255.255
!
interface GigabitEthernet0/0/0           (to 7609)
 ip address 12.1.1.2 255.255.255.252
 speed 1000
 no negotiation auto
 mpls ip
 mpls label protocol ldp
!
interface GigabitEthernet0/0/1      (to 2950 )
 no ip address
 speed 100
 no negotiation auto
 service instance 101 ethernet
  encapsulation dot1q 101
  bridge-domain 101
 !


router eigrp 90
 network 10.10.10.102 0.0.0.0
 network 12.1.1.0 0.0.0.3
!
********************************
CE configuration like this:  access mode 

CE1: 
interface FastEthernet1/0/1
 switchport access vlan 101
 switchport mode access
end

interface Vlan101
 ip address 192.168.20.10 255.255.255.0
end


CE2 :
interface FastEthernetF0/1
 switchport access vlan 101
 switchport mode access
end

interface Vlan101
 ip address 192.168.20.20 255.255.255.0
end
*************************************
ASR1004#SHOW MPLs L2transport VC DETail 
Local interface: VFI aaa vfi up
  Interworking type is Ethernet
  Destination address: 10.10.10.101, VC ID: 101, VC status: down
    Last error: Remote peer access circuit is down
    Output interface: Gi0/0/0, imposed label stack {17}
    Preferred path: not configured  
    Default path: active
    Next hop: 12.1.1.1
  Create time: 22:24:49, last status change time: 00:00:33
    Last label FSM state change time: 21:17:13
  Signaling protocol: LDP, peer 10.10.10.101:0 up
    Targeted Hello: 10.10.10.102(LDP Id) -> 10.10.10.101, LDP is UP

 

7609#show mpls l2transport vc detail 
Local interface: VFI aaa vfi up
  Interworking type is Ethernet
  Destination address: 10.10.10.102, VC ID: 101, VC status: down
    Last error: MPLS dataplane reported a fault to the nexthop

    Output interface: none, imposed label stack {}
    Preferred path: not configured  
    Default path: no route
    No adjacency
  Create time: 1d12h, last status change time: 21:18:20
    Last label FSM state change time: 00:00:40
  Signaling protocol: LDP, peer 10.10.10.102:0 up
    Targeted Hello: 10.10.10.101(LDP Id) -> 10.10.10.102, LDP is UP

 

 

 

 

585
Views
0
Helpful
4
Replies
CreatePlease to create content