Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

vpn pptp

I configure pptp vpn on cisco 2811, when users connected to our head office as remote vpn client they did not get default gateway and my local DNS.

can anyone help in these problem, how i can assign my default gateway and mylocal dns to remote vpn client.

regards,

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: vpn pptp

hello ,

below pptp config you can reference to .

vpdn enable

!

vpdn-group pptp

accept-dialin

  protocol pptp

  virtual-template 1

interface Ethernet0/1

description connect to isp

ip address 202.18.14.148 255.255.255.248

ip nat outside

load-interval 30

full-duplex

!

interface Virtual-Template1

ip unnumbered Ethernet0/1

peer default ip address pool 1

ppp authentication pap chap

ppp ipcp dns 152.104.168.162 152.104.228.251

ip nat inside

!

ip local pool 1 192.168.104.112 192.168.104.115     #### assign lan ip address for remote client

4 REPLIES
New Member

Re: vpn pptp

hello ,

below pptp config you can reference to .

vpdn enable

!

vpdn-group pptp

accept-dialin

  protocol pptp

  virtual-template 1

interface Ethernet0/1

description connect to isp

ip address 202.18.14.148 255.255.255.248

ip nat outside

load-interval 30

full-duplex

!

interface Virtual-Template1

ip unnumbered Ethernet0/1

peer default ip address pool 1

ppp authentication pap chap

ppp ipcp dns 152.104.168.162 152.104.228.251

ip nat inside

!

ip local pool 1 192.168.104.112 192.168.104.115     #### assign lan ip address for remote client

New Member

Re: vpn pptp

Thanks wang

i am testing that one only.

regards

New Member

Re: vpn pptp

Dear Wang,

        yes vpn remote client get local dns ip address.  But i have one question that default gateway is 0.0.0.0 and subnet mask is getting 255.255.255.255.

can you help to define subnet mask should be "C" class and default gateway from the vpn test pool ip address.  It is possible to assign default gateway and subnet mask to remote vpn client.

regards,

New Member

Re: vpn pptp

hello ,

pptp vpn , remote client get the internal ip address ,and the mask is 255.255.255.255 . this is define by pptp , we cannot change anything.

0.0.0.0 mean that all data include vpn flow and internet from pc to destination ,should forward to remote router .

1203
Views
0
Helpful
4
Replies
CreatePlease to create content