Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

vpnv4 connected routers not cummunicating

I have 4 routers connected as per sketch below, I can ping my directly connected VRF's from both PE's(R2 can ping R1 and R3 can also ping R4). My PE's cannot ping each other.

both these PE's are running BGP 1000

then R4 BGP 65001 and R1 BGP 6500

(CE)R1 - R2(PE) -- (PE)R3 - R4(CE)

R2(PE)

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface ATM3/0.100 point-to-point

ip address 165.148.120.2 255.255.255.252

no atm enable-ilmi-trap

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community both

exit-address-family

!

!

R3(PE)

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

!

interface ATM1/0.100 point-to-point

ip address 165.148.120.1 255.255.255.252

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

address-family vpnv4

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 send-community both

neighbor 4.4.4.4 next-hop-self

exit-address-family

!

I suspect the problem is with my MPLS cloud(vpnv4).

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: vpnv4 connected routers not cummunicating

Lawrence,

When you say "PEs cannot ping each other", do you mean they can't ping each other directly connected interface address (atm1/0.100) or their respective loopback addresses?

Do you have a routing protocol running between the two PEs? If so, do see the neighbors loopback address?

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
1 REPLY
Cisco Employee

Re: vpnv4 connected routers not cummunicating

Lawrence,

When you say "PEs cannot ping each other", do you mean they can't ping each other directly connected interface address (atm1/0.100) or their respective loopback addresses?

Do you have a routing protocol running between the two PEs? If so, do see the neighbors loopback address?

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
110
Views
0
Helpful
1
Replies