Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VRF across L3 switch link

I have two 3560s connected via a Layer 3 portchannel. I have two vlans on switch A and one VLAN on switch B that i want to be in the same VRF. The rest of the VLANs on both switches i dont want in a VRF...

Im using OSPF for VRF and non VRF router advertisements...

how can i do this with an L3 link connecting the two switches?

TIA

  • WAN Routing and Switching
2 REPLIES

Re: VRF across L3 switch link

If i understand you correctly, i think you can have the desired vlans with the same RT & RD values and enable VRF FWD on those particular vlan SVI's?

Narayan

Re: VRF across L3 switch link

If it is VRF lite, the easiest way would be to crate a GRE tunnel between the two switches and put it in your VRF. So assuming each switch has a Loopback address of 192.168.1.1 and 192.168.1.2 it would look as follows;

interface Tunnel1

description VRF Link between switches

ip vrf forwarding VRF_NAME

ip address 10.0.0.1 255.255.255.252

tunnel source Loopback0

tunnel destination 192.168.1.2

!

router ospf xxxx

address-family ipv4 vrf VRF_NAME

network 10.0.0.0 0.0.0.3 area 0

!

That would create a L3 link across the GRE tunnel in your VRF and allow OSPF to establish a neighbor for that particular VRF.

Then just place the VLAN SVI's into your vrf;

interface Vlan100

ip vrf forwarding VRF_NAME

If you previously had an IP address assigned to the SVI, you will need to reassign it after putting it in a VRF.

195
Views
0
Helpful
2
Replies
This widget could not be displayed.