Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VRF Aware EtherChannel

Hello,

I am trying to confiure Layer 3 port channel between 6006  and cisco 4503 switch.

Existing connection between them is a layer 3 link with IP address and VRF configured.

Can I move the VRF and IP address on to the Port-channel interface and hope all to work well ?

Existing config.

interface GigabitEthernet0/1

ip vrf forwarding ABC

ip address 10.10.10.1 255.255.255.248

New Port-channel config

interface port-channel 1

ip vrf forwarding ABC

ip address 10.10.10.1 255.255.255.248

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,3,4,5

switchport mode trunk

channel-group 1 mode on

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,3,4,5

switchport mode trunk

channel-group 1 mode on

Thanks

3 REPLIES
Cisco Employee

VRF Aware EtherChannel

Hi,

It is possible to put a Layer3 EtherChannel into VRF without problems. However, the configuration would be as follows:

!

interface GigabitEthernet0/1

no switchport

channel-group 1 mode on

!

interface GigabitEthernet0/2

no switchport

channel-group 1 mode on

!

interface port-channel 1

ip vrf forwarding ABC

ip address 10.10.10.1 255.255.255.248

Notice that the no switchport commands must be present on the physical interfaces, removing the Layer2 switching functionality from the Gi0/1 and Gi0/2 before creating an L3 EtherChannel.

Best regards,

Peter

New Member

VRF Aware EtherChannel

Thanks Peter. I believe Gig 0/1 and 0/2 are native layer 3 interface but I will keep no switchport in mind when configuring.

Thanks

Salmaa

Cisco Employee

VRF Aware EtherChannel

Hi Salmaa,

Oh, on 6500 and similar platforms, they are L3 by default - you're right. I am more accustomed to 3560 and similar which default to L2 operation. In any case - if they are L3 by default then all the switchport mode trunk and switchport trunk ...  commands you've indicated in your config have no meaning anyway.

Best regards,

Peter

289
Views
0
Helpful
3
Replies