Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

vrf-lite

hi all..

i am trying to understand vrf-lite much better than I am now. Pleasea advice me..

Lets say I have this network :

R1(CE1)--172.16.1.0--R2--192.168.1.0--R3--172.16.2.0--R4(CE2)

From R2 there is also a link out to internet. Lets say this is a default route..

I have a customer (X) behind R1 who also have a office behind R4..

I am running ospf on R2 between some other routers in that core.

This is where I want to use vrf-lite.. I want to be able to make another routing process on R2 that only have routes that is for customer X locations. This are privat ip ranges, so I dont want them in to my ordernary routing table.

I can do this makeing the routing process attached to vrf X, right?

Then, this is the config :

R2

interface g0/1

ip vrf forwarding X

describtion to CE1

interface g0/2

ip vrf forwarding X

describtion to R3

interface g0/3

ip vrf forwarding X

describtion to Internett

(do I need the ip vrf forwarding X command on g0/3 so that customer X are able to reach the internet??)

ip vrf X

rd 1:1

route-target export 1:1

route-target import 1:1

router ospf 2 vrf X

log-adjacency-changes

capability vrf-lite

network 172.16.0.0 0.0.255.255 area 0

default-information originate always

router ospf 1

log-adjacency-changes

network 192.168.0.0 0.0.255.255 are 0

default-information originate always

ip route 0.0.0.0 0.0.0.0 10.0.0.1

R3

interface g0/1

ip vrf forwarding X

describtion to CE2

interface g0/2

ip vrf forwarding X

describtion to R2

ip vrf X

rd 1:1

route-target export 1:1

route-target import 1:1

router ospf 2 vrf X

log-adjacency-changes

capability vrf-lite

network 172.16.0.0 0.0.255.255 area 0

default-information originate always

router ospf 1

log-adjacency-changes

network 192.168.0.0 0.0.255.255 are 0

default-information originate always

So, what I wonder is several things. With this config, will an user that are on the internet be able to reach a server in location at customer X? since this is not taged with vrf X?.. If not what do I need to do so that anybody can reach a web server in customer X either location.

Will customer X also be able to reach internet?, if not what do i need to do?..

CE 1 only have a default route to R2, but CE2 have an ospf process with R3. Do this process need to be both routing processes from R3(both ospf vrf X and the ordernary)?

I hope somebody can help me understand this a litle better, I have tried to read some about this, but are not able to get the full picture..

Thanks

JP

1 REPLY
Silver

Re: vrf-lite

capability vrf-lite

To suppress the Provider Edge (PE) specific checks on a router when the OSPF process is associated with the VRF, use the capability vrf-lite command in router configuration mode. To restore the checks, use the no form of this command.

capability vrf-lite

no capability vrf-lite

This URL should help you:

http://www.cisco.com/en/US/products/hw/optical/ps2006/products_configuration_guide_chapter09186a00803bbeed.html

359
Views
0
Helpful
1
Replies
CreatePlease to create content