Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VRF routes into IGRP.

Hi,

I am having issue to redistributing 2 vrf-lite routes into my LAN L3 switches.My topology is as below,

PE router having two bgp peering with my CE,

On CE, I having 2 separet routing tables, which I need forwarding to my 2 LAN swiches running EIGRP.

I did try to redistribute BGP into EIGRP but no route is comming into EIGRP, I also configured Static route to forward my one vrf routes to next hop , but still not working. please see my config on CE.

Please note, we need to keep routes sepreate from CE to two lan L3 switches.

CE-3750#

rd 800:1

!

ip vrf lite3

rd 900:1

!

interface GigabitEthernet1/0/2

des"connection to-1st-LAN switch"

no switchport

ip vrf forwarding lite2

ip address 11.1.1.1 255.255.255.252

interface Vlan2

ip vrf forwarding lite2

ip address 100.1.1.1 255.255.255.252

!

interface Vlan3

ip vrf forwarding lite3

ip address 200.1.1.1 255.255.255.252

!

router eigrp 11

redistribute bgp 800

network 11.0.0.0

auto-summary

router bgp 800

network 11.1.1.0

bgp log-neighbor-changes

!

address-family ipv4 vrf lite3

redistribute connected route-map TEST

neighbor 200.1.1.2 remote-as 100

neighbor 200.1.1.2 activate

neighbor 200.1.1.2 route-map TEST out

no auto-summary

no synchronization

network 20.1.1.1 mask 255.255.255.255

exit-address-family

!

address-family ipv4 vrf lite2

redistribute connected route-map TEST

neighbor 100.1.1.2 remote-as 100

neighbor 100.1.1.2 activate

neighbor 100.1.1.2 route-map TEST out

no auto-summary

no synchronization

network 11.1.1.0 mask 255.255.255.0

exit-address-family

ip route vrf lite2 0.0.0.0 0.0.0.0 11.1.1.2

!

!

4 REPLIES
Cisco Employee

Re: VRF routes into IGRP.

Make sure you either configure a default-metric under the address-family ipv4 vrf xxx or set the metric as part of the route-map as follow:

router eigrp 11

address-family ipv4 vrf lite3

default-metric

address-family ipv4 vrf lite2

default-metric

or

route-map TEST permit

set metric

Redistribution will not take place without this.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: VRF routes into IGRP.

Hi,

I have changed the config on ce as below, but still unable to recieve Eigrp routes on LAN-SW.

on CE

---

router eigrp 11

redistribute bgp 800

network 11.0.0.0

auto-summary

!

address-family ipv4 vrf lite2

redistribute bgp 800

default-metric 1500 1000 1 255 1500

auto-summary

exit-address-family

on LAN-SW

LAN-SW1#sh ip ro

Gateway of last resort is not set

11.0.0.0/30 is subnetted, 1 subnets

C 11.1.1.0 is directly connected, GigabitEthernet1/0/2

LAN-SW1#sh ip eigrp nei

LAN-SW1#sh ip eigrp neighbors

IP-EIGRP neighbors for process 11

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

0 11.1.1.1 Gi1/0/2 13 00:01:58 8 200 0 3

LAN-SW1#

Cisco Employee

Re: VRF routes into IGRP.

Mohammed,

On the 3750, Can you do a "show ip ro vrf lite2" and "show ip eigrp vrf lite2 topo".

Also if you could try adding the command "autonomous-system 11" under the address-family ipv4 vrf lite2 to see if it solves the issue.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: VRF routes into IGRP.

Hi, I have added the autonomous-system 11 command, but the routes are not in Topology table, please see the output below,

Routing Table: lite2

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

100.0.0.0/30 is subnetted, 1 subnets

C 100.1.1.0 is directly connected, Vlan2

172.16.0.0/24 is subnetted, 1 subnets

B 172.16.1.0 [20/0] via 100.1.1.2, 2d19h

10.0.0.0/32 is subnetted, 1 subnets

C 10.1.1.1 is directly connected, Loopback1

CE#sh ip eigrp vrf lite2 top

IP-EIGRP Topology Table for AS(11)/ID(10.1.1.1) Routing Table: lite2

CE#

230
Views
5
Helpful
4
Replies
CreatePlease to create content