Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vrf with pppoe

Good day,

I try a test lab yesterday. I configure a router as NAS:

This router terminate the pppoe and assign vrf to each client via a radius server. But i see that when pppe client belong to a vrf it doesn't receive ip address, there is not problem with authentication.

Linux free Radius configuration:

Service-Type = Framed-User,

Framed-Protocol = ppp,

cisco-AVPair = "lcp:interface-config=ip vrf forwarding MTNNS-NET",

Framed-IP-Address = 3.3.3.2,

Framed-IP-Netmask = 255.255.255.0,

cisco-avpair="lcp:interface-config=encapsulation ppp",

cisco-avpair="lcp:interface-config=ip address 3.3.3.3 255.255.255.0",

Router configuration:

aaa new-model

aaa authentication ppp default group radius

aaa authorization network default group radius

vpdn enable

vpdn-group 1

access dialin

protocol pppoe

virtual template 1

interface f0/0

description connection to server

ip address 1.1.1.1 255.255.255.0

interface f0/1

description client acces

ip address 2.2.2.2 255.255.255.0

pppoe enable

3 REPLIES
New Member

Re: vrf with pppoe

Hi all,

please, let me know if my answer is not clear ?

Regards.

New Member

Re: vrf with pppoe

Hello,

did you get to a solution for this issue?

I am in the need of providing a similar solution: vrf with PPPoE. I still cant find the way to do it so I would appreciate any help.

As far as I can see, this solution is supported by means of a Radius server.... do you know if there is a way to do this manually, I mean that the config is static and resides in the PE?

Thanks a lot in advance,

Nataniel

Re: vrf with pppoe

You don't need an address on fas0/1 just to get pppoe working, but it's ok to have it there if you need it for other reasons. Your posted config doesn't contain config of Virtual-Template 1 interface. Do you have it?

lcp:interface-config =

ip vrf forwarding \n

ip address

(Above is single line in RADIUS profile)

Is all what you need to get an IP address on the interface. No ppp, no anything of that kind - all general and common configs go to Virtual-Template.

Hope this helps.

1623
Views
0
Helpful
3
Replies
CreatePlease login to create content