Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VTP or VLAN.DAT strange behaviour

Hello,

Sorry for this newbie question , but in my small CCNA LAB I have :

CISCO 1841 (with 4 ethernet por module to be able to use VTP in this router) + CISCO 2940

From one of the optional module in the CISCO 1841 I go with a trunck to the CISCO 2940.

The CISCO 1841 is VTP SERVER and the CISCO 2940 is CLIENT.

When I create in the CISCO 1841 the VLAN DATABASE of the 3 VLAN's :

VLAN 1 name VLAN1

VLAN 2 name VLAN2

VLAN 10 name VLAN10

After WR ; copy run  start ; reload  everithing work fine in my small ROUTER on a STICK demo.

So I am sure that VTP is working and that the Password and Domain are correct in both products.

BUT ......

If I switch OFF the Power of BOTH (Switch & Router) the VLAN 2 and 10 are gone. In other word the system use a default VLAN.DAT or create a NEW empty database !!!

When I compare the VLAN.DAT before and after the a power down I can see that before it is or has 1124 BYTES and after 740 BYTES.

Before I recycle the Power ON / OFF I made a Back-Up of the VLAN.DAT to VLAN.BAK. To make it work again I just have to copy bak VLAN.BAK to VLAN.DAT ; reload and everithing work again.

Why is the ROUTER creating a new empty DATABASE ?

To solve the problem I have set both ROUTER and SWITCH in TRANSPARANT mode and now it works , but I was wondering why this happens.

Thanks to this small lab I learned that their is a BIG difference between RELOAD and a power recycle.

The above is not a real case so it is not urgent , I just prepare my self for my CCNA in october

Best Regards,

Didier

Everyone's tags (4)
3 REPLIES
New Member

VTP or VLAN.DAT strange behaviour

Hello,

Just for your information , I solved the problem by creating the VLAN's in the CONFIG TERMINAL and NOT in the VLAN DATABASE.

In a other 2621XM ROUTER when I create something in the VLAN DATABASE , it will show it in the SCRIPT , here in the 1841 it do not show.

My idea is that when I do a reload he use the VLAN DATABASE and when I restart , he write a empty VLAN DATABASE and use this empty database, this was why I coud see that the VLAN.DAT was always created at the time and day from the reboot.

I hope this information will be usefull for some people.

PS: The IOS from the CISCO1841 is 12.4(13r)T , the IOS on the CISCO2621XM is 12.4(24)T.

Best Regards,

Didier

New Member

VTP or VLAN.DAT strange behaviour

New Member

VTP or VLAN.DAT strange behaviour

SOLVED

498
Views
0
Helpful
3
Replies
CreatePlease login to create content