Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WAN Configration

Dear All

Please help me in configuring my Cisco 837 router for ADSL service.

I am finish my CCNA 6days back tried to configure by my self but couldn?t succeed also tried to contact my ISP they say that they don?t support for Cisco might be they don?t know. As my ISP just gave me the WAN connection type Settings here are they

Connection Type: 1483 Bridged Ip LLC

PVC VPI: 0 VCI: 32

Multiplexing: LLC

Qos: UBR

NAT Should Enable

Please help!!

Thank in Advance

Zia Khan

8 REPLIES

Re: WAN Configration

Hi Zia,

Please find the cisco 800 series router configuration guide. Its has all the neccessary config commands and the example and should help you:

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118d1a.html

HTH,Please rate if it does.

-amit singh

Community Member

Re: WAN Configration

Zia Khan,

I am attaching a sample config and do the needed changes in IP addressing according to your network and hopefully this should work without any issues.

version 12.3

!

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname <# HOSTNAME #>

!

logging buffered 10000 debugging

no logging console

!

enable secret <##################>

!

username <##################> password <##################>

!

clock timezone EST 10

!

no aaa new-model

!

ip subnet-zero

!

no ip domain lookup

!

ip cef

!

bridge irb

!

ip audit notify log

ip audit po max-events 100

!

no ftp-server write-enable

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0 (or change accordingly)

ip nat inside

no keepalive

hold-queue 100 out

no shut

!

!

interface ATM0

no ip address

no ip directed-broadcast

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

no shut

!

interface ATM0.1 point-to-point

bridge-group 1

pvc 0/32

ubr ###

encapsulation aal5snap

!

!

interface BVI1

ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX *

no ip directed-broadcast

ip nat outside

!

ip nat inside source list 11 interface BVI1 overload

ip classless

!

ip route 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX **

no ip http server

no ip http secure-server

!

bridge 1 protocol ieee

bridge 1 route ip

!

access-list 11 remark *** Address space for NAT

access-list 11 permit 192.168.1.0 0.0.0.255

!

line con 0

exec-timeout 5 0

privilege level 15

password 0 <# ACCESS PASSWORD #>

login

!

line vty 0 4

exec-timeout 5 0

privilege level 15

password 0 <# ACCESS PASSWORD #>

login

!

end

* - YOUR WAN ADDRESS

** - NEXT HOP ADDRESS FOR THE DEFAULT GATEWAY

Hope this might help you.

Best Regards

Rajesh

Community Member

Re: WAN Configration

Dear Rajesh

Thank for your prompt response. The configuration what your have given to me is with the user name and the password my connection does not required and user name and the password as my ISP says that it?s the DHCP connection it does not require any user name or the password. Please check this configuration which I have tried to configure but it doesn?t work please let me know if any information required .

Router1#sh run

Building configuration...

Current configuration : 2359 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router-1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret xxx.

!

clock timezone KSA 3

no aaa new-model

ip subnet-zero

!

!

!

!

ip cef

ip domain name yourdomain.com

ip ips po max-events 100

no ftp-server write-enable

!

!

no ip routing

bridge 1 protocol ieee

!

no crypto isakmp enable

!

!

!

interface Loopback0

ip address 1.6.7.x.x.255.255

!

interface Ethernet0

no ip address

bridge-group 1

!

interface ATM0

no ip address

pvc 0/32

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

mtu 1492

ip address 10.201.3.2 255.255.255.252

no ip redirects

no ip unreachables

ip accounting output-packets

ip flow ingress

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer-group 1

!

router rip

version 2

network 1.0.0.0

network 10.0.0.0

network 192.168.190.0

!

ip classless

!

no ip http server

no ip http secure-server

!

!

access-list 100 deny tcp any any eq 445

access-list 100 deny udp any any eq 445

access-list 100 deny tcp any any eq 135

access-list 100 deny udp any any eq 135

access-list 100 deny tcp any any eq 137

access-list 100 deny udp any any eq netbios-ns

access-list 100 deny udp any any eq netbios-ss

access-list 100 deny tcp any any eq 139

access-list 100 deny icmp any any

access-list 100 permit ip any any

dialer-list 1 protocol ip permit

!

!

control-plane

!

!

line con 0

no modem enable

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

privilege level 15

password xxx

login

transport preferred all

transport input all

transport output all

!

scheduler max-task-time 5000

end

BR

Zia Khan

Silver

Re: WAN Configration

Try to follow the link from Amit, check the DHCP configuration section and follow the template. It tells how to configure DHCP + ATM connection in the router. It is helpful.

http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a0080118d1a.html#wp1016512

Hope this helps.

Community Member

Re: WAN Configration

Hi,

The username and password which appears on the sample config is your login credentials and which is not related to the CHAP or PAP.

Try using the above said sample configs and ask your ISP for the Default gareway address. You can use the below DHCP as a sample for configuring the dhcp server.

ip dhcp pool YOURPOOL

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX

Also, is there any reason for using the routing protocal (rip) ????

Thanks

Rajesh

Community Member

Re: WAN Configration

Dear Rajesh

Please help me in solving this problem, if you want I will let you access the router. I tried all my best but couldn?t fix the problem.

BR

Zia Khan

Silver

Re: WAN Configration

I found there is no IP at Etherent interface, please assign your private address.

Please try below commands that extract from the sample and fine tuned for your setting.

ip routing

bridge irb

interface Ethernet0

ip address x.x.x.x y.y.y.y

no ip directed-broadcast

ip nat inside

no bridge-group 1

interface ATM0

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

bundle-enable

no pvc 0/32

no encapsulation aal5snap

interface ATM0.1 point-to-point

no ip directed-broadcast

pvc 0/32

encapsulation aal5snap

bridge-group 1

interface BVI1

ip address dhcp client-id Ethernet0 <-- This help to get the IP address from ISP via DHCP

no ip directed-broadcast

ip nat outside

ip nat inside source list 1 interface BVI1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 BVI1

access-list 1 permit x.x.x.x z.z.z.z <-- your Ethernet segment address

bridge 1 protocol ieee

bridge 1 route ip

Please let us know the result and the error message if it fails.

Hope this helps.

Re: WAN Configration

Hi,

You can also try binding the dialer interface to the ATM under the ATM interface config

pppoe-client dial-pool-number 0

Hope this helps

regards

vanesh k

119
Views
0
Helpful
8
Replies
CreatePlease to create content