Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WAN Design

All-

Our client wants to setup a new site with two WAN circuits to their MPLS. I am attaching the diagram with two options we want to implement. There are very heavy traffic for those two WAN circuits.

For the inbound traffic to the CPE router, customer wants to few hosts (e.g 20.20.20.0/28) to go thru the WAN1, and all other traffic will go thru WAN 2 link. If WAN 1 link goes down, ALL traffic will go thru the WAN2 link; If WAN 2 link goes down, ALL traffic will go thru the WAN1 link.

For the oubound trffic from the CPE router, customer wants the subnet 100.100.100.0/24 to go thru the WAN1 link, and all other traffic will go thru WAN2 link. If WAN 1 link goes down, ALL traffic will go thru the WAN 2 link; If WAN 2 link goes down, ALL traffic will go thru the WAN 1 link.

What are the pros and cons on Option1 and Option 2? The sample on how to configure on routing protocol BGP regarding of my scenario will be helpful.

Regards,

Joe

Everyone's tags (2)
10 REPLIES
New Member

WAN Design

Any suggestion is greatly appreciated!

Super Bronze

WAN Design

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

Suggestion would be use both paths proportionally, and use QoS.

New Member

WAN Design

Thanks!. I am looking on the BGP routing configuration.

Re: WAN Design

If you are using single CE with multiple PE, then use the below config to do load balancing

interface gi0/0

ip address 10.10.10.1 255.255.255.252

no ip route-cache

interface gi0/1

ip address 11.11.11.1 255.255.255.252

no ip route-cache

router bgp x

neighbor 10.10.10.2 remote-as 10

neighbor 10.10.10.2 route-map Set_MED_LAN1_Out

neighbor 11.11.11.2 remote-as 10

neighbor 11.11.11.2 route-map Set_MED_LAN2_Out

route-map Set_MED_LAN1_Out permit 10

match ip address 1

set med 100

route-map Set_MED_LAN1_Out permit 20

set med 200

route-map Set_MED_LAN2_Out permit 10

match ip address 2

set med 100

route-map Set_MED_LAN2_Out permit 20

set med 200

access-list 1 permit 100.100.100.0 0.0.0.255

access-list 2 permit 200.200.200.0 0.0.0.255

Thanks / Samy

New Member

WAN Design

Thanks Samy! Couple questions...1) I want to set up the inbound traffic control on the CPE router, let's say we only permit the subnet 30.30.30.0/24 to come in on WAN1 link, and the other traffic on WAN2 link, and if one of them goes down, the ALL traffic will go to the other link. 2) For the inbound traffic control, should the ISP need to configure anything on their end? 3) What is the difference to use "set med", " set orgin igp" and " set local preference"? in my case, which is the best fit?

WAN Design

Either you can use "MED" or AS_PATH.

Thanks / Samy

New Member

WAN Design

Samy, what's pros and cons to to have two router, and each one has one link? Thanks!

New Member

Re: WAN Design

If you have one router with two links and the router fails, your network down.

If you use two router, and one router fails, you still have one router with one link.

Regards

Sent from Cisco Technical Support iPad App

New Member

WAN Design

Thanks Handoko, I still have two questions...

1) I want to set up the inbound traffic control on the CPE router, let's say we only permit the subnet 30.30.30.0/24 to come in on WAN1 link, and the other traffic on WAN2 link, and if one of them goes down, the ALL traffic will go to the other link. 2) For the inbound traffic control, should the ISP need to configure anything on their end?

New Member

Re: WAN Design

You can manipulate inbound traffic by using community attribute to prepend as-path

Sent from Cisco Technical Support iPhone App

544
Views
0
Helpful
10
Replies