Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WAN Failover, 2 2811 routers, 2 ISP

Hey guys,

I'm new at this but the company I work for now is asking me to set up a redundant/failover network for them. At the moment we have two (2) 2811 routers and two (2) ISPs. These connect to a 3560 switch before connecting to our domain server. What would be the best protocol to use so that when one ISP goes down, the other will kick in and we'll still be able to access our domain server?

By the way, both ISPs do not use serial interface. They connect directly to the FastEthernet port.

Any help will do.

Thanks.

Everyone's tags (4)
4 REPLIES

WAN Failover, 2 2811 routers, 2 ISP

Hi Ian,

one of the ways could be:

a) EIGRP or OSPF internally to quickly re-route if a 2811 fails or the uplink to one 2811

b) eBGP to the ISP (RAM memory considerations may impose you to have not the full routing table)

c)iBGP in between the 2811s

To this scenario, very easy EEM scripts or object tracking or IP SLA can be applied. I would NOT use HSRP or similar in the core network but this is your choice. Another possibility is with simple static routes but with PBR or changing the longest match (two static routes one less specific than the other one) or even changing administrative distance.

Enhanced object tracking could be quite effective. Much depends anyway on which policies you want to implement on the core network routers (2811s)

Hope this helps

Alessio

New Member

WAN Failover, 2 2811 routers, 2 ISP

well if this is going to be used ONLY for users going on the internet then you don't even need routers.

now assuming you do need 2 routers then I would go like this,

which isp is my mian so one isp will be my main, the one with more bandwidth.

the other is your backup.

so on your main router where the main isp is connected to lets say port 0/0

config t

ip route 0.0.0.0 0.0.0.0 fa0/0

router eigrp 100

network 10.0.0.0

no auto-summary

now I,m assuing you're connecting your stuff together using the 10 subnet.

then you do the same on your backup router except this time

ip route 0.0.0.0 0.0.0.0 fa0/0 200

access-list 99 permit any any

router eigrp 100

network 10.0.0.0

no auto-summary

offset-list 99 out 100 fast 0/1

assuming 0/1 is connected to your switch.

now both your routers are connected into a layer 3 switch.

then on the layer 3 you also have

router eigrp 100

network 10.0.0.0

tried this in gns3 and it works just fine.

gl.

Silver

WAN Failover, 2 2811 routers, 2 ISP

From my experience IP SLA is the quickest/easiest thing to do to get it working

---

Posted by WebUser John Wilson from Cisco Support Community App

VIP Purple

WAN Failover, 2 2811 routers, 2 ISP

Hi Wayne,

please look this post .....this is same as urs:

https://supportforums.cisco.com/thread/2040405

Regards

1626
Views
0
Helpful
4
Replies