Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WAN link load balancing

We are adding a second ISP and I am looking for a sufficient router to provide load balancing between the two ISPs.  I am also kicking around the idea of forgetting the router and just making the T1 a backup route if the WiMax goes down, using only the ASA5510.

Currently have:

T1(ISP Router) <-> ASA5510 <-> LAN

Looking to have:

T1 (ISP Router)       <->

                                          Router ?    <->     ASA 5510  <->  LAN

WiMax(ISP Router) <->

Thanks in advance for any suggestions

Jay

7 REPLIES
Hall of Fame Super Bronze

Re: WAN link load balancing

Are you looking into internet load-balancing with 2 different ISPs?

Did they give you an public IP address block? I'm sure the other ISP will give you another public IP address block.

Are you using BGP?

Regards,

Edison

New Member

Re: WAN link load balancing

ediortiz wrote:

Are you looking into internet load-balancing with 2 different ISPs?

Did they give you an public IP address block? I'm sure the other ISP will give you another public IP address block.

Are you using BGP?

Regards,

Edison


1. Yes. Each link will be from a different ISP.

2. Each ISP will be supplying a block of IPs.

3. We currently only have the single T1 link using the ISP owned router.  The handoff to us is ethernet to our ASA5510.

I would prefer to use some type of Load Balance/Load Share to not have the T1 sitting there doing nothing.

New Member

Re: WAN link load balancing

If this would be your topology

T1 (ISP Router)       <->

                                          Router ?    <->     ASA 5510  <->  LAN

WiMax(ISP Router) <->

Then I believe you can have load-sharing but not load-balancing where you can define a group of users from ur lan subnet to take one path and the rest of the users to take another, and in case of failure of one path, all users take the path that is up and working using some route-maps or ipslas.. but I dont think you can have something as per packet basis.

If both the ISPs are same and if they provide multilink or bvi then in that case you may change the load-sharing to per-packet basis. I dont think SPs provide this luxury..

New Member

Re: WAN link load balancing

considering your current setup, you can do load balancing with redundancy (protecting data traffic during failure) using GLBP (Gateway load balncing protocol). Gateway Load Balancing Protocol (GLBP) protects data traffic from a failed router or circuit, like Hot Standby Router Protocol (HSRP) and Virtual Router Redundancy Protocol (VRRP), while allowing packet load sharing between a group of redundant routers.

Regards

Sameer

New Member

Re: WAN link load balancing

sameer.mulgund wrote:

considering your current setup, you can do load balancing with redundancy (protecting data traffic during failure) using GLBP (Gateway load balncing protocol). Gateway Load Balancing Protocol (GLBP) protects data traffic from a failed router or circuit, like Hot Standby Router Protocol (HSRP) and Virtual Router Redundancy Protocol (VRRP), while allowing packet load sharing between a group of redundant routers.

Regards

Sameer

Which router would you suggest to pull this off?

New Member

Re: WAN link load balancing

As far as I know, the 6500 series MLS is the only device that supports GLBP according to the CCNP switch book documentation.

New Member

Re: WAN link load balancing

hello,

if we are playing on the BGP metrics, can i know the destination learnt by both the ISP, please find the attachment and i hope that is the scenario you have in that case i suggest you to go for 2821 router and 2 port ethernet card if the ISP are ready to give the link on ethernet handoff

please find the 2821 router configuration

In this scenario, load balancing is not an option in a multihomed environment, so you can only do load sharing.

You cannot do load balancing because BGP selects only a single best path to a destination among the BGP routes that are

learned from the different ASs

interface gi0/0

ip address x.x.x.x 255.255.255.252

no ip route-cache

interface gi0/1

ip address x.x.x.x 255.255.255.252

no ip route-cache

router bgp x

neighbor x.x.x.x remote-as 10

neighbor x.x.x.x route-map over-T1 in

neighbor x.x.x.x remote-as 20

neighbor x.x.x.x route-map over-wimax in

auto-summary

route-map over-T1 permit 10

match ip address 1

set weight 100

route-map over-T1 permit 20

match ip address 2

route-map over-wimax permit 10

match ip address 2

set weight 100

route-map over-wimax permit 20

match ip address 1

access-list 1 permit 10.10.10.0 0.0.0.255

access-list 2 permit 20.20.20.0 0.0.0.255

in this scenario if you have learned 10 n/w over ISP T1 router and traffic destined to this from you LAN will also go on the same link,please let me know your destination n/w so that we can play on that

2243
Views
0
Helpful
7
Replies
CreatePlease login to create content