Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Wan Link Redundancy and HSRP configuration in Routers

Hi All,

i am planing to configure WAN redundancy using ospf in routers. Currently we are using only one router and planing to install second in live environment.Please  suggest about the configuration in Primary and secondary router for redundancy so that if wan link will be down then the traffic can pass through secondary.Below is configuration of my primary router.

 

Note:

 

1. Primary Router Gi0/0 is connected to MPLS.

2. Fe0/0/0.10 is connected to L3

3.We will connect Secondary Router to MPLS using separate Link

4. One interface of secondary router would be connected to L3.

5. Want to confirgure HSRP also as mentioned few commands in Fe0/0/0.10

 

interface GigabitEthernet0/0
 description ***Connected to MPLS
 ip address 192.168.x.x
 ip ospf network point-to-point
 ip ospf cost 1
 load-interval 30
 duplex full
 speed 100
!
interface GigabitEthernet0/1
 description "P2P 30 Mb Link"
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/0/0
 no ip address
 ip flow egress
 duplex auto
 speed auto
!
interface FastEthernet0/0/0.10
 encapsulation dot1Q 10
 ip address 10.66.29.1 255.255.255.0
 standby 29 ip 10.66.29.3
 standby 29 priority 110
 standby 29 preempt
 !
interface FastEthernet0/0/1
 no ip address
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric-type 1 subnets
 redistribute static metric-type 1 subnets
 network 192.168.x.x 0.0.0.3 area 0
 distribute-list 45 in
!
ip forward-protocol nd
ip route 10.66.32.0 255.255.255.0 10.66.29.4
ip route 10.66.39.192 255.255.255.192 10.66.29.4
ip route 172.19.248.0 255.255.255.192 10.66.29.4

1 REPLY

Hello.I would use track

Hello.

I would use track object to track reachability of some (major) prefix (or a couple of them) via WAN link (on primary router).

If prefix is not learnt, this will decrement HSRP priority and make it lower than on secondary.

No need to have the same tracking on secondary. Make sure you have preempt.

381
Views
0
Helpful
1
Replies